Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
BI & Data Trends 2021. Discover the top 10 trends emerging in today. Join us on Dec. 8th REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Qlik Sense server own domain SSL certificate not working

Hi all,

After a lot of efford my own domain certificatie is still not working for my Qlik Sense server.

Let my explane my server settings and what I've already done:

Server: Windows Server 2012 R2

Installed Qlik Sense  -> everything working fine

IIS not installed

Now I would access the QMC and Hub from my own local computer with my own domain name.

Also this is working fine accept de red lock in my browser:

2015-09-11 09_56_18-Qlik Management Console.png

The lock is telling my that still the standard Qlik CA certificate is binded to de ports:

2015-09-11 09_58_42-Qlik Management Console.png

The following I've already done:

- generate a CSR through MMC on the server

- buy a SSL certificate for my own domain with the generated CSR

- import the certificate in Local Computer -> Personal -> Certificates

- add a value to de virtual proxy with my domain name

- add the thumbprint from the certificate to de security section of de proxy:

2015-09-11 10_05_40-212.114.111.238 - Verbinding met extern bureaublad.png

- Stopped all Qlik Sense services

- Bind the certificate to the ports through netsh http [del][add] sllcert ipport=0.0.0.0:4244 and 443 etc.

- Delete the standard CA Qlik Sense certificates

- Start all the Qlik Sense services

After restarting the services I notice that all the standard CA certificates are added again by the QS software.

The bindings for port 4244 and 443 are overruled and put back to the thumbprint from the standard QS CA certificate

It looks like QS is not recognizing my thumbprint and everytime the service is restarted it is falling back on the standard QS CA certificate.

2015-09-11 10_04_50-212.114.111.238 - Verbinding met extern bureaublad.png

Is this a bug? If not, what do I have to do to get a proper SSL connection to my server with my own domain from my local computer?

Thanks in advance.

10 Replies
Highlighted
Not applicable

Nobody a solution?

Highlighted
Not applicable

Hello Rick,

I spoke to Hassan Rageh from Qlik "Solution Specialist Benelus" and he asked if you have an support contract. If so he can help you.

Highlighted
Not applicable

Fixed!

After updating to Sense server 2.1 it's working like a charme.

So it looks like a bug in the previous version.

Highlighted
Not applicable

Very Nice and the result looks very good! 

Highlighted
Partner
Partner

i'm have same issue with QS server 2.1.1

but i'm generete CSR in Open SSL

Highlighted
Creator II
Creator II

Good Morning.

Same situation here. Could we ALL get a clear post where this kind of issue is explained clearly ?

Thanks.

Highlighted
Partner
Partner

everything as first message. only small note.  You need crete  PFX file from paste cer+key files.

install this PFX certificate.

Highlighted
Contributor III
Contributor III

Hello,

I have verion 3.0.0 and I am facing the same issue, can you please tell me if you had to install IIS?

Highlighted
Contributor III
Contributor III

And I have a same problem Can anybody help me?