Qlik Community

Qlik Sense Integration, Extensions, & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Not applicable

Can't run QlikSenseTask.exe

Hi All.

Here is my situation:

When i run my bat file to run the qliksensetask.exe in a server it is able to run successfully.

However when i run the batch job from outside the server, it will give me an error of this:

Error,"System.Exception: Bad Request: Cannot find a task with the following name: TaskName

   at QlikSenseJSONObjects.QlikSenseJSONHelper.StartTaskByName(String taskname, Boolean synchronous)

   at QlikSenseTask.Program.Main(String[] args)"

2016_08_25_02_46_16,Information,"Returning Errorlevel 8"

The input I put in was this:

qliksensetask.exe -task:"TaskName" -proxy:http://localhost -wait:600

Thanks in advance!

3 Replies
Not applicable

Re: Can't run QlikSenseTask.exe

We are facing same issue. Any luck that you got this fixed?

tiegsti_solomon
New Contributor

Re: Can't run QlikSenseTask.exe

Please share if you solved this issue

ellen_andresen
New Contributor

Re: Can't run QlikSenseTask.exe

Hi!

1. Make sure the task actually exist. Go to sense QMC, and choose Tasks under MANAGE CONTENT, and find your task there. Make sure you use the task name and not the associated resource when running qliksensetask.

2. Don't have any funny characters in the task name. I got a problem with a '&' in the task name.

Community Browser