Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Getting "No connection" message when trying to open a document from webpage

It works fine for a while, but after some days(randomly how many) the users get an error message saying "No connection" when they try to open the document from the web client.

On the same time it works fine to open the document in the desktop application from the server.

A restart of the "Qlikview Server" windows service solves the problem, before it occurs again.

1 Solution

Accepted Solutions
Not applicable
Author

Hi Atleesperum,

The message is related that Qlikview Server is not responding you... There are several reasons for that.

1- As Miguel said it may be a communication problem because of your server name or domain name.

2-There is a working set limit in Qlikview Server Performance options. If you load a lot of data to your document, then sometimes qlikview could not manage this working set limit because of windows limitations(Sometimes virtual machines can cause that). In that case qlikview server may not response you even if your ram is not loaded fully.

In your case if you get the message randomly, then it may be related this working set parameter. If you decreased it before try to increase it to %85-%90. If you still geting no connection message,

-Decrease the load of your doucments

or

-Increase the Ram Amount of your Server.

Hope this helps

Kerem Pekçabuk

Senior BI Consultant

View solution in original post

7 Replies
Miguel_Angel_Baeyens

Hi,

Are there any proxies in your network between the client and the QlikView Webserver? Are you using the QVWS or IIS? Is the name of your server large? Did you try setting the IP address in the QEMC instead of the name of the server? Is your license a valid AJAX license (there were some limitiations in previous versions of QlikView)?

Hope that helps.

Miguel

Not applicable
Author

Are there any proxies in your network between the client and the QlikView Webserver?

No

Are you using the QVWS or IIS?

We are using QVWS.

Is the name of your server large? Did you try setting the IP address in the QEMC instead of the name of the server?

The server name is not large, but the users are using a dns name that are 17 characters  long. Not sure where you belive I should use ip address instead.

Is your license a valid AJAX license (there were some limitiations in previous versions of QlikView)?

I belive so. We bougth the server license after  QV11 was released.

Thx,

Atle

Miguel_Angel_Baeyens

Hi,

Then I'd suggest you to log a case with Support so they can check your environment and give a better advice.

Miguel

Not applicable
Author

Hi Atleesperum,

The message is related that Qlikview Server is not responding you... There are several reasons for that.

1- As Miguel said it may be a communication problem because of your server name or domain name.

2-There is a working set limit in Qlikview Server Performance options. If you load a lot of data to your document, then sometimes qlikview could not manage this working set limit because of windows limitations(Sometimes virtual machines can cause that). In that case qlikview server may not response you even if your ram is not loaded fully.

In your case if you get the message randomly, then it may be related this working set parameter. If you decreased it before try to increase it to %85-%90. If you still geting no connection message,

-Decrease the load of your doucments

or

-Increase the Ram Amount of your Server.

Hope this helps

Kerem Pekçabuk

Senior BI Consultant

Not applicable
Author

Hi

It was the RAM that was the issue. Got help from support, and they suggested to select "load only one document in memory". The problem has not happen again after we did that.

Atle

omerfaruk
Creator
Creator

Hi,

I was having the same issue and restarting the IIS Server solved it.

In case sb else faces..

Thanks.

Samaha
Contributor
Contributor

It worked for mee too.

Thanks