Qlik Community

Ask a Question

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
Showing results for 
Search instead for 
Did you mean: 

Not able to use all CPU Cores of server in Qlik processing.

Hi All,

I have a single node Production environment and my CPU cores are 96 with 2 socket with RAM 1 TB.

so i should get 96*2 checkbox in CPU affinity in QMC under system tab-->Setup--> QVS--> Performance

but i get only 48 checkbox and performance is degraded due to it.

Further i checked there are 4 groups in which CPU cores is divided on Server (of 24 cores Each)

My assumption is Qlik is using only one and therefore 48 processors checkbox is showing and not 96*2.

checked NUMA too.

I am failing to get all CPU cores to work for qlik.

Need help in getting to solution.


Sudhanshu Shrivas

1 Reply

Check the settings for hemisphere mode (disabled), NUMA (disabled) or node interleaving (enabled). All three refer to the same technology but the name varies depending on the vendor, including hypervisors.

If you see 4 groups of processors, looks like it is a 4 socket server, most of which are not recommended because how the QPI link is built and the time it takes to jump from one CPU to the next with available memory, which basically means NUMA cannot be disabled.

Also, how many are the physical cores? Intel allows to enable hyperthreading which creates two threads for each physical core. This is not set up by default and needs to be checked with the vendor, some hypervisors or cloud services, like AWS already provide threads, not physical cores.

Even that, hyperthreading in a 4 socket computer can have a bigger impact in performance for the worse, as there are more CPUs available but not interconnected.


Quick tips #8 - Server Settings For Best Performance