Skip to main content

QlikView Administration

Discussion Board for collaboration on QlikView Management.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
kevinpintokpa
Creator II
Creator II

QlikView 12 kills scheduled tasks after waiting for 45 minutes for an engine

We recently upgraded to QlikView 12.  I noticed today that a key scheduled task had not started for some reason.  After digging through the Publisher log file (Root_2018xxxx.txt), I found the following:

20180507T064501.532-0500 Information TriggerState: Change State to Ignored. Task="My Task Name", ExecId=6773395f-57f9-445f-94a8-bd450028f311. Trigger ScheduleTrigger ignored. No QlikView Engine was available after waiting for 45 minutes.

It is really unacceptable to not start a task like this and without any error notification of any kind.  It can have many consequences, often resulting in stale data.  In my case, an entire sequence of Production tasks was left quietly unexecuted!

My question:  Is there a way to disable this bug or at least change the 45 minutes to a much larger time period?

1 Solution

Accepted Solutions
Peter_Cammaert
Partner - Champion III
Partner - Champion III

This is not a bug and this behavior was exactly the same in 11.20. After 45 minutes waiting for a free reload engine, the QDS will simply give up.

There are a few solutions for your situation:

  • either configure more reload engines. See QMC->System->Setup->Distribution Services->Your QDS->Advanced->QlikView Engine. You should not configure more reload engines than there are cores in your server CPU(s).
  • or (and this probably existed in the old environment, but you may have forgotten to take it along when upgrading to v12), increase the wait period for a reload engine to become available. See Re: Server-Task delaying

Best,

Peter

View solution in original post

2 Replies
Peter_Cammaert
Partner - Champion III
Partner - Champion III

This is not a bug and this behavior was exactly the same in 11.20. After 45 minutes waiting for a free reload engine, the QDS will simply give up.

There are a few solutions for your situation:

  • either configure more reload engines. See QMC->System->Setup->Distribution Services->Your QDS->Advanced->QlikView Engine. You should not configure more reload engines than there are cores in your server CPU(s).
  • or (and this probably existed in the old environment, but you may have forgotten to take it along when upgrading to v12), increase the wait period for a reload engine to become available. See Re: Server-Task delaying

Best,

Peter

kevinpintokpa
Creator II
Creator II
Author

Thanks, I followed your second option of increasing the QvbWaitTimeoutMinutes from 45 to 90 minutes.  That seemed to be enough for my environment.  No silent failures today!