Skip to main content
Announcements
Live today at 11 AM ET. Get your questions about Qlik Connect answered, or just listen in. SIGN UP NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
dusingh-c
Contributor
Contributor

The QlikView Management Console displays "QDS@Cluster is down" and the status of all tasks is listed as “Unrunnable" for Build Number 12.60.20200.0

Hi QlikView Admins,

The QlikView Management Console under Status tab displays its Distribution Service as "QDS@Cluster is down" under Started/Scheduled column and lists all tasks as "Unrunnable" for status. This is happening after the windows OS was migrated to 2019 from 2016, we are running QlikView May 2021 SR2 version - Build Number 12.60.20200.0.

Symptoms: Tasks are running for long hours overnight and next morning we see the same error  "QDS@Cluster" is down.

We tried to follow the implement the below changes to increase the communication between Management and Distribution service but to no avail, we again came across the same error "QDS@Cluster" is down under Started/Scheduled column and lists all tasks as "Unrunnable" for status.

https://community.qlik.com/t5/Knowledge/QlikView-Tasks-status-in-the-Management-Console-Unrunnable/t...

Could someone please advise if they came across similar issue in their experience.

Thanks in Advance 

Regards,

Durgesh

Labels (2)
2 Solutions

Accepted Solutions
Ray_Strother
Support
Support

Hello ,

Please confirm the following :

 

1.  Turn off the services

2. Adjust the setting below:

https://community.qlik.com/t5/Knowledge/The-QlikView-Management-Console-displays-147-Cluster-is-down...

Open the Management Service config file located in C:\Program Files\QlikView\Management Service\QVManagementService.exe.config and look for the following lines and adjust the size lower (.i.e 75), restart the service and recheck the QMC\Status view.

<!-- Message size for QMS workorder -->
adjust from : <add key="QMSChunkSize" value="100"></add>
adjust to : <add key="QMSChunkSize" value="xxx"></add>

try the following values one at a time for xxx : 75, 65, 55, 45

adjust from : <add key="MaxReceivedMessageSize" value="262144" />

Adjust to : <add key="MaxReceivedMessageSize" value="26214400" />

View solution in original post

Chip_Matejowsky
Support
Support

Hi @dusingh-c,
The 'unrunnable" tag & message "Cluster is down" is indicative that the QlikView Management Service (QMS) and the QlikView Distribution Service (QDS) have lost synchronization and can be a common issue.  In addition to Ray's advice, have a look at the Qlik whitepaper Scaling the QlikView Publisher which details some configuration changes you can enable via the config files for the QMS & QDS to improve performance.  

Suggest that you compare what you currently have configured in %ProgramFiles%\QlikView\Management Service\QVManagementService.exe.config and %Program Files%\QlikView\Distribution Service\QVDistributionService.exe.config to what is suggested in the whitepaper.  Feel free to post back here if you have any questions.

Best Regards

 

Principal Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!

View solution in original post

2 Replies
Ray_Strother
Support
Support

Hello ,

Please confirm the following :

 

1.  Turn off the services

2. Adjust the setting below:

https://community.qlik.com/t5/Knowledge/The-QlikView-Management-Console-displays-147-Cluster-is-down...

Open the Management Service config file located in C:\Program Files\QlikView\Management Service\QVManagementService.exe.config and look for the following lines and adjust the size lower (.i.e 75), restart the service and recheck the QMC\Status view.

<!-- Message size for QMS workorder -->
adjust from : <add key="QMSChunkSize" value="100"></add>
adjust to : <add key="QMSChunkSize" value="xxx"></add>

try the following values one at a time for xxx : 75, 65, 55, 45

adjust from : <add key="MaxReceivedMessageSize" value="262144" />

Adjust to : <add key="MaxReceivedMessageSize" value="26214400" />

Chip_Matejowsky
Support
Support

Hi @dusingh-c,
The 'unrunnable" tag & message "Cluster is down" is indicative that the QlikView Management Service (QMS) and the QlikView Distribution Service (QDS) have lost synchronization and can be a common issue.  In addition to Ray's advice, have a look at the Qlik whitepaper Scaling the QlikView Publisher which details some configuration changes you can enable via the config files for the QMS & QDS to improve performance.  

Suggest that you compare what you currently have configured in %ProgramFiles%\QlikView\Management Service\QVManagementService.exe.config and %Program Files%\QlikView\Distribution Service\QVDistributionService.exe.config to what is suggested in the whitepaper.  Feel free to post back here if you have any questions.

Best Regards

 

Principal Technical Support Engineer with Qlik Support
Help users find answers! Don't forget to mark a solution that worked for you!