Skip to main content
Announcements
Product Release Webinar: Qlik Insider airing December 6! REGISTER TODAY!
cancel
Showing results for 
Search instead for 
Did you mean: 
godfreydaniels
Contributor III
Contributor III

Can't hide rows with all 0's in QV table

Hi,

I have a QlikView table with the following:

  1. several dimensions
  2. a number of hidden expressions
  3. a hidden expression that evaluates those expressions to determine whether the row should appear
  4. visible versions of the expressions in (2), but which first check (3), and display 0 if it is false.

'Suppress zero-values' is checked.

The resulting table shows all dimensions. The rows that should appear show the correct values, and the other rows correctly show 0 in every column. But the all-0 rows fail to hide. The zero-values are true zeroes, not a rounding issue. Am I correct that 'Suppress zero-values' should consider only visible columns?

Dimension limits will not work in this case because of a separate issue.

Thanks

1 Solution

Accepted Solutions
godfreydaniels
Contributor III
Contributor III
Author

I tried a different way in which there are no hidden columns that return nonzero values unless the row is meant to be displayed, and this version works.  So it seems hidden columns can cause the 'suppress zero-values' setting to be ignored.

View solution in original post

1 Reply
godfreydaniels
Contributor III
Contributor III
Author

I tried a different way in which there are no hidden columns that return nonzero values unless the row is meant to be displayed, and this version works.  So it seems hidden columns can cause the 'suppress zero-values' setting to be ignored.