Skip to main content
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
Showing results for 
Search instead for 
Did you mean: 
Not applicable

EDX - Problem with authentication NTLM


I am working on EDX and I am having this error:

The HTTP request is unauthorized with client authentication scheme 'Ntlm'. The authentication header received from the server was 'NTLM'.

in this line:

Taks = Client.GetTasks(Guid.Empty)

I am working in a virtual machine and I am trying execute a task from a server.

If I execute the app in the server will work?


3 Replies
Partner - Contributor
Partner - Contributor


I tried to exceute EDX on my laptop and  I had the same problem.

Did you solve it?


Former Employee
Former Employee


The users connecting through the API must be members of the QlikView Management API security group. The group is not created during the installation and has to be added (and populated, for example, with the members of the QlikView Administrators group) manually. A membership in this group is required to import tasks from another QlikView Server/Publisher.


Bill - Principal Technical Support Engineer at Qlik
To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.
Partner - Contributor
Partner - Contributor

Hi Bill,

thank you for reply but I obtain the same error.

I'm not expert about c# and I'm trying to execute QMSEDX code posted at this link

QMSEDX Enhanced

When I tried to create a Visual Studio Solution I obtained the same authentication error importing QMSAPI.

Any suggest?

thank you in advance