Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
tseebach
Luminary Alumni
Luminary Alumni

Last 12 values dimension limits

Hi, does anyone know how to get Dimension Limits to show the last 12 values in a chart rather than the first 12. I've tried -12, which gives af nonsense result.

In QV 10 it was possible using the Max Visible Number function under presentation. But In QV11 it does not seem to work.

18 Replies
Not applicable

Any news on this? I'm having exactly the same problem with my R12-figures showing only the last year. They worked fine until upgrading from QV10 to QV11.

Olof Laurin, Senior Consultant at Tacticus AB, http://www.tacticus.se

tseebach
Luminary Alumni
Luminary Alumni
Author

Sorry no, we running QV10 for now with clients that have any types of rolling charts.

Not applicable

But if your dimension is simple for example year&month you can use "Largest" instead of the desired "Last". In these cases

Largest and = (Max(PeriodCounter) - Min(PeriodCounter) + 1) solves my case.

Olof Laurin, Senior Consultant at Tacticus AB, http://www.tacticus.se

Not applicable

I did some more testing and I think it is a bug that Largest works directly because it should take Largest of first expression values but at least for line charts it ignores that and uses Largest for first of dimensions instead.

But for tables it works as expected, the Largest acts on the first expression, but it is easy to add your dimension yearmonth also as an expression, then the dimension limit Largest works on that. Also for tables the feature on presentation show max number of values works excellent to clip the future tail of R12-values, for example =count(DISTINCT yearmonth). This does not seem possible on line charts.

The dimension limits would be easier to understand and use if it incorportaed both Last and the Show Max Number of values.

Olof Laurin, Senior Consultant at Tacticus AB, http://www.tacticus.se

Not applicable

I just discovered we have this problem on a couple of our reports. Have you found solution? Has Qlikview issued a response to this problem. Seems like a major oversight not have a Dimension limit of Last.

Not applicable

A workaround that sometimes works is to:

1. Add a new expression with your dimension as the expression

2. Put the new expression first.

3. Make it invisible (uncheck display option or on presentation tab depending on graph type)

4, Set dimension limit to Largest of first expression.

However if you have a set-expression involving your dimension the results seems somewhat unpredicatable (or at least I havn't understood what's going in).

Olof Laurin, Senior Consultant at Tacticus AB, http://www.tacticus.se

beanmachine
Contributor III
Contributor III

Here is a solution we use to replicate what was available in QV10 and earlier in QV11.

  • Switch off any dimension limits
  • In the Presentation tab, tick 'Enable X-Axis Scrollbar'
  • Set 'When Number of Items Exceeds' to a the level that suits you
  • Tick 'Reversed'

This will show you the last X (for instance, months) in the correct order.  You can scroll back to the left to show lower values but the default will be to show the last X values from the maximum.

This seems to do the trick although it would be easier if the Dimension Limits included a 'Last' setting to replicate what we had before the upgrade.

Not applicable

Hello,

Elly had sent a test scenerio of the rolling 12 months and I noticed that you are generating calendar values in a spreadsheet that you then pull into QV.  The data associated to MonYearCalName is recognized as a text value therefore when you sort it will be alphabetically rather than chronologically.  This can be corrected by generating a master calendar in QV which will create the value as a date or numeric value.  Once that is done, choosing Largest 12 in the Dimension Limits tab should give you what you want.

There are several samples of setting up master calendars posted in the community.

Not applicable

This worked perfectly for me.

I have a chart with a variable dimension (day, week, year) and I wanted to show only the last 10 days (or weeks or years) and this did the trick.

Thank you very much!