Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

List box selection - not affected by "Clear all"

Dear Community,

I have a special condition where I need select "Client Name" by default in list box,

even user clicks "Clear all selection", Client Name will still be selected.

I have my default selection done with Sheet trigger --> add action --> on activate sheet --> select field.

But once I click "Clear all selection", everything will be clear, what can i do to select "Client Name" always be selected?

Thanks,

Chanel

15 Replies
MK_QSL
MVP
MVP

Go to your list box.

select Client Name

Now under List Box Properties

select always one selected value

tresesco
MVP
MVP

Select one value from the list box->Properties->General tab-> Check 'Always One Selected Value'

Not applicable
Author

Thanks for prompt response!

However, it shows in grey so i can't activate it.

is it because this field is system dimension?

Not applicable
Author

Thanks for fast response!

As shown in previous reply, i am not able to activate it, not sure is because of system dimension?

Not applicable
Author

Hi,

Keep one value selected in the list box then only the "Always One Selected Value" option will be enabled. Then go to properties and check "Always One Selected Value".

jsingh71
Partner - Specialist
Partner - Specialist

Hi,

Select below option in list box property,this will not clear your selection even you click on clear all also.listbox.png

tresesco
MVP
MVP

No, you have to select a value from the list first, and then only you will find it selectable.

MK_QSL
MVP
MVP

Go to your list box.

select Client Name

Now under List Box Properties

select always one selected value

Read my previous post... You need to select at least one value first then only this property is available.

Not applicable
Author

Refer to my attached image in previous post, i have selected one value but it is still not working, in grey color...

so i wonder is it related to system dimension (%_dimensions) ?

Thanks,

Chanel