Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Read about the latest Qlik Community enhancements on the Community News blog!
cancel
Showing results for 
Search instead for 
Did you mean: 
paul_ripley
Creator III
Creator III

Macro parse failed: Functionality was lost

Hello

We have a macro that exports objects to Excel.  We run it from the access point.  It works for a group of users but for others they get the message

Macro parse failed: Functionality was lost

exportToExcel_variant3     (which is the macro name)

Error: ActiveX component cant create object. 'Excel.Application'

The users have allowed macros, so I don't think this is the reason.

It works for me but I am an admin on the server (as I think the others users are who can run the macro - could just be a coincidence?)

Does anyone have any idea if there is an IE setting controlling this?

Thanks

Paul

1 Solution

Accepted Solutions
beck_bakytbek
Master
Master

Hi Paul,

try this : Ctrl+Shift+M and then Check: Give System Access to Module Script

macro.PNG

let me know if you solve your issue

i hope that helps

View solution in original post

13 Replies
colin_albert

Are all of your users using the same client (IE Plugin or Ajax)?

marcus_sommer
MVP & Luminary
MVP & Luminary

This error meant that ActiveX isn't enabled and/or that the users didn't allow the macro system-access (could be changed within the settings.ini from each user or within the gui per pressing ctrl+shift+m and choosing there the third option).

- Marcus

beck_bakytbek
Master
Master

Hi Paul,

try this : Ctrl+Shift+M and then Check: Give System Access to Module Script

macro.PNG

let me know if you solve your issue

i hope that helps

View solution in original post

paul_ripley
Creator III
Creator III
Author

Hi Colin

Yes they are all IE Plugin

Paul

paul_ripley
Creator III
Creator III
Author

Hi Marcus

The did ctrl+shift+m  and "give system access to module script" was already ticked (as it is for me)

Paul

paul_ripley
Creator III
Creator III
Author

Hi Beck

They did ctrl+shift+m  and "give system access to module script" was already ticked (as it is for me)

Paul

beck_bakytbek
Master
Master

Yes Paul,

Try to activate it

marcus_sommer
MVP & Luminary
MVP & Luminary

Then ActiveX is disabled on the user-side. This could be done directly through the various ActiveX settings or through more global settings like using the protected mode or using of a high security-level and didn't add the access point to the trusted sites or something similar.

- Marcus

paul_ripley
Creator III
Creator III
Author

Hi that did work after all - Many thanks for your help