Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

On May 18th at 10AM EDT we will answer your QlikView questions live. REGISTER
Showing results for 
Search instead for 
Did you mean: 
Not applicable

[Microsoft][ODBC SQL Server Driver][SQL Server]Invalid object name

Hi, From the QV script, I connected to my SQL data source OK and selected a table to read from OK. The resulting script looked OK. I added ADD ONLY before LOAD and did a Partial Load. I got this  " ... ErrorMsg: [Microsoft][ODBC SQL Server Driver][SQL Server]Invalid object name ... " .

I am successfully loading data from 3 other SQL DBs, this is the first time that I am seeing this error when trying to load from a 4th DB using the same method.. Any ideas on what is going on.?

Thanks ...

4 Replies
Creator III
Creator III


Would you mind sharing the load script containing the problem?

Maybe it's syntax related problem that you haven't thought of.


Not applicable

check for the instance(SID)

Not applicable

Hi, Thanks for the help. I got it too work but this was a little strange. In the past, I have connected to more than 1 SQL DB on various servers from one QVW. Recently, I created a QVW and tried to do the same thing, connect to more than 1 SQL DB. I have each Connection and the resulting Loads in tabs of thier own. But what is happening is that the first Connect encountered dominates the rest of the script for that QVW, regardless of how many other Connects there are, the rest seem to be ignored. The connect that I was having a problem with is downstream of another, so when I tried to Load it was looking at the SQL DB from the first Connect, and, of course, it could not find the object there. Remember, this has worked for me in the past. Why now? I seem to be having a problem with memory (I think QV is hogging most of it), so maybe this behavior is the result of that. So my solution (for now), I have created several QVWs for each Connect, keeping the Connects to the different SQL DBs away from each other. But is this the best way to do it? Anyones thoughts? Thanks ..

Not applicable


Thanks for your reply.

Here was the cause. Trying to connect to two different SQL databases from scripts existing in different tabs but in the same QVW is not working. The first connect rules, and the 2nd connect does not seem to have any effect, thus the second load is trying to read from the first connect and hence the "Object Not Found".

I have opened multiple SQL DBs in the same QVW before, so I am not sure why it is a probem here. My solution was to create two QVWs, one for each connect (the QVWs are building QVDs, no graphics).