Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
alexis
Partner - Specialist
Partner - Specialist

Mouse over linear gauge question

Hi,

In the example below I am using a "gauge" object to show a result of a calculation of (expression=X/Y) in a linear gauge.

The gauge has been setup using a Min of 0 and a Max of 2 and the result is specified as a percentage to show the result of the calculation which it does just fine.

When I hover over the chart I see the result (106% in this case) as you can see below - the user needs to see the values of X and Y as a popup (or some other means) when they hover over the "region". Any suggestions?

Thanks in advance

hover.jpg

1 Solution

Accepted Solutions
alexis
Partner - Specialist
Partner - Specialist
Author

I have managed to solve this myself:

a) In the single expression that I had I unchecked the "Text as pop-up"

b) I created another expression and for that one I checked "Text as pop-up"

In that expression I defined:


= chr(10) &

  'X= ' & X1 & chr(10) &

  'Y= ' & Y11 & chr(10) &

  'Diff =' & num(X1-Y11)


The result can be seen below.
The initial line-feed chr(10) above was used to separate the result (106%) which for some reason I cannot stop it from appearing, from the items (X, Y and Difference) that I wanted to show on the pop-up. Hope this is useful to someone!

hover2.jpg

View solution in original post

6 Replies
alexis
Partner - Specialist
Partner - Specialist
Author

I have managed to solve this myself:

a) In the single expression that I had I unchecked the "Text as pop-up"

b) I created another expression and for that one I checked "Text as pop-up"

In that expression I defined:


= chr(10) &

  'X= ' & X1 & chr(10) &

  'Y= ' & Y11 & chr(10) &

  'Diff =' & num(X1-Y11)


The result can be seen below.
The initial line-feed chr(10) above was used to separate the result (106%) which for some reason I cannot stop it from appearing, from the items (X, Y and Difference) that I wanted to show on the pop-up. Hope this is useful to someone!

hover2.jpg

morganaaron
Specialist
Specialist

Hi Alexis,

If you go to the presentation tab and at the bottom un-tick 'pop-up labels', I think this should still show your calculated labels but will suppress your initial label. Glad you got it sorted otherwise!

alexis
Partner - Specialist
Partner - Specialist
Author

Hi Aaron,

Thanks for responding.

Unfortunately, if you uncheck the "Popup-labels" you lose all pop-ups so I'm going to have to leave with the unnecessary result value for the benefit of having the other values which are needed - if anybody knows how to solve it completely then I will be very happy!!

regards

Alexis

morganaaron
Specialist
Specialist

What version of Qlikview are you using? I've got three expressions, my bottom two with "text as pop-up" ticked, top one without. On the presentation tab I've also then unticked pop-up labels, but if I hover my mouse over my chart, I can still see the labels for the other two expressions.

Talking that out-loud, it sounds like that probably isn't meant to happen though, so may be a bug with my version? I'm using v11.2 SR10.

alexis
Partner - Specialist
Partner - Specialist
Author

I have 2 expressions the first without "text as pop-up" and the bottom with.

If I uncheck "pop-up labels" nothing shows and when I check it then the popup shows the values of both of the expressions...

I'm using 11.20.12451.0 SR7 64-bit Edition (x64)

morganaaron
Specialist
Specialist

Just checked (as I have a version of SR7 as well) and you're entirely correct, so this must be a bug in SR10. Will report - apologies it hasn't solved your issue though!