Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
cancel
Showing results for 
Search instead for 
Did you mean: 
darrellbutler
Creator
Creator

Oracle OLE DB Provider

Hi Folks,

I've just got a new laptop. I've installed QV but when I want to connect to Oracle databases I cant see the Oracle OLE DB provider in the data link properties box. I've installed Oracle Provider for OLE DB (11.2.0.2.0) from ODAC 11.2 Release 3 , I thought this might do the trick but it hasn't any ideas ?Many thanks

Darrell.

1 Solution

Accepted Solutions
rbecher
MVP
MVP

But the website says 32-bit:

http://www.oracle.com/technetwork/topics/dotnet/utilsoft-086879.html

You should install the Microsoft Windows (x64) Client:

http://www.oracle.com/technetwork/database/enterprise-edition/downloads/112010-win64soft-094461.html

2. Paragraph: Oracle Database 11g Release 2 Client

- Ralf

Vizlib Head of R&D

View solution in original post

4 Replies
rbecher
MVP
MVP

Could this be a 32/64bit issue? Which version you are running?

- Ralf

Vizlib Head of R&D
darrellbutler
Creator
Creator
Author

Ralf,

I'm using 64bit QV, laptop is 64 bit but it looks like the ODAC components are 32Bit - although in saying that the system requirements for ODAC are:

System Requirements

======================================================

The following items are required for ODAC:

  • Windows operating system
    • 32-bit: Windows 7 (Professional, Enterprise, Ultimate editions), Windows Server 2008, Windows Vista (Business, Enterprise, Ultimate editions), Windows Server 2003, Windows Server 2003 R2, Windows XP Professional
    • x64: Windows 7 (Professional, Enterprise, Ultimate editions), Windows Server 2008 R2 and Windows Server 2008 (all editions, except HPC), Windows Vista (Business, Enterprise, Ultimate editions), Windows Server 2003, Windows Server 2003 R2, Windows XP
  • Microsoft .NET Framework 2.0, 3.0, 3.5, or 4
    Note: .NET Framework 1.x is not supported.
  • Access to an Oracle Database Server (Oracle 9i Release 2 or later)
rbecher
MVP
MVP

But the website says 32-bit:

http://www.oracle.com/technetwork/topics/dotnet/utilsoft-086879.html

You should install the Microsoft Windows (x64) Client:

http://www.oracle.com/technetwork/database/enterprise-edition/downloads/112010-win64soft-094461.html

2. Paragraph: Oracle Database 11g Release 2 Client

- Ralf

Vizlib Head of R&D

View solution in original post

darrellbutler
Creator
Creator
Author

Cheers Ralf - this worked, one thing to be careful about though is to do a custom install as the oracle ole db provider soesn't install by default you have to select it.

Many ThanksDarrell