Qlik Community

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
QlikWorld online is next week! REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
cristian_av
Creator III
Creator III

Preceding Load not Working with Group By

I, I'm using a Preceding with Group BY, but I can't make it work!

When I execute the script, I get the error "Field Ld_Fecha not found"

Is there anything wrong with my code?

Thanks!!

Concatenate (VolumenCreado)

LOAD *, Date(Ld_fecha,'YYYYMM') as PeriodoNum;

LOAD

  FirstValue(Right(mes,4)) as Periodo,

  FirstValue('01-'&Left(mes,2)&'-'&Right(mes,4)) as Ld_Fecha,

     'Vol.Ppto' as [OrigenVol],

     //FirstValue(espe_codigo),

     FirstValue(espe_nombre) as espe_nombre,

     //FirstValue(coge_codigo),

     'Casa Matriz' as coge_nombre,

     FirstValue([Clave Sip]) as ctmv_codigo,

     Sum(volumen) as Volumen,

     'Generado' as TipoVol

FROM [file.xlsx] (ooxml, embedded labels, table is Hoja1)

GROUP BY Periodo, mes, espe_nombre, [Clave Sip];

1 Solution

Accepted Solutions
stabben23
Master
Master

maybe a typo

FirstValue('01-'&Left(mes,2)&'-'&Right(mes,4)) as Ld_Fecha,

LOAD *, Date(Ld_fecha,'YYYYMM') as PeriodoNum; small f

View solution in original post

2 Replies
stabben23
Master
Master

maybe a typo

FirstValue('01-'&Left(mes,2)&'-'&Right(mes,4)) as Ld_Fecha,

LOAD *, Date(Ld_fecha,'YYYYMM') as PeriodoNum; small f

stabben23
Master
Master

And Periodo is not a valid Field in Group by