Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
May 18th 10AM ET, Live Chat, bring your QlikView questions. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Qlikview 11 for developers - Pie chart formatting

How do I add the percentages ?

Untitled.jpg

1 Solution

Accepted Solutions
Joseph_Musekura
Support
Support

Dear John,

There is a known bug that was found in some version of
Qlikview (example version11.20SR3). In 11.20SR3, % on Pie chart is not
displayed. This was corrected from QlikView desktop v 11.20SR4. If you are
using such version you will need to update to latest version ex 11.20SR5 to be
able to view % in Pie chart.

/jo

View solution in original post

13 Replies
Not applicable
Author

1. To get the percentages instead of actual values, check 'Relative' on the Expression tab in the properties.

2. To get the percentages to show up on the graph, check 'Values on Data Points' on the Expression tab in  the properties.

Hope that helps!

Not applicable
Author

1.Go to Expression Tab

2. On the display Options check the 'Value On data points'

Then you will get percentages

Capture.PNG.png

Not applicable
Author

select pie chart - properties - check on 'Relative' and 'value on data points' check boxes

Not applicable
Author

Thanks venu. But, how do I get the percentages as shown ? I tried setting percentage in Number tab and I get a different result -

Capture.JPG.jpg

santharubban
Creator III
Creator III

see the pic

its_anandrjs

Use num function for the expression

Like

Num( YourExpression,' #,##0.00 ' )

Not applicable
Author

you need to check  on 'relative' check box in properties - expressions tab

oknotsen
Master III
Master III

On the expressions tab, select the expression.

In the mid-middle of the tab,right above "display options", you will find "Relative". This will turn the results of the expression into a percentage of the total of the expression. This will automatically turn the number formatting into showing the result as a percentage and all answers will total to 100%.

May you live in interesting times!
Not applicable
Author

Got it ! But the percent % sign is missing. How do I get that ? In number tab, I chose Number with precision = 4, show in percent.