Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Qlikview and ODBC Connections

I'm trying to set up my Qlikview dashboard to run using ODBC connection.  I can get the QVW to connect to the ODBC connection I've made and when I run in the desktop it runs fine.  However when I publish the dash board, it fails.  Lookin gin the logs it seems that it is trying to access the database using the service account that Publisher is running as.  Is there something I'm missing?

9 Replies
Nicole-Smith

1)  The ODBC connection needs to exist in the "ODBC Data Source Administrator" on the server that the dashboard is running from.  If it doesn't exist there, it will not run.

2)  If you don't want it to use the service account as the login for the database, you can use whatever username and password you want when doing your connect statement in your load script in QlikView:

Untitled.png

avinashelite

1.You need to add the ODBC DSN name in the server with the same Connection name you have created in the QVW app

2.Your QV Service account should have access for DB

Not applicable
Author

Not applicable
Author

Where is the ODBC Datasource administrator?  Is it a Qlikview feature?  the ODBC connection is set up in Windows And I did add the UID and PW in the screen you show above, but I still get the error that says my service accountdoes not have access to the database.

Nicole-Smith

I was referring to setting up the ODBC connection in Windows.

When you hardcode the UID/password, does it work on your machine and still only break when you move it to the server?  If so, it sounds like something is wrong with server permissions, and I'm not sure how to go about fixing this...

Not applicable
Author

When I test the ODBC connection after setting it up it works fine. When I then use it in the code

ODBC CONNECT TO Netwrix (XUserId is xxx, XPassword is yyy);

I see an error in the log that says the service account, not userid XXX, does not have permissions. I don’t understand why it is trying to connect as the service account.

kaushiknsolanki
Partner Ambassador/MVP
Partner Ambassador/MVP

Hi,

Try to create a system DSN instead of User DSN.

I am sure it will work.

Regards,

Kaushik Solanki

Please remember to hit the 'Like' button and for helpful answers and resolutions, click on the 'Accept As Solution' button. Cheers!
Not applicable
Author

It is a system DSN

kaushiknsolanki
Partner Ambassador/MVP
Partner Ambassador/MVP

A small Question.

While opening the "Set up ODBC" did you run it as admin.

If not then try to open as Admin and then create a new system DSN and try that.

Not sure this will work or not but just a check point.

Regards,

Kaushik Solanki

Please remember to hit the 'Like' button and for helpful answers and resolutions, click on the 'Accept As Solution' button. Cheers!