Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join this live chat April 6, 10AM EST - QlikView to Qlik Sense REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Why can't I add totals to my Pivot Table?

Hi guys,

I have a simple pivot with resource name as the first dimension, months as the second and a SUM of 'days booked' as the expression.

I have made it a cross table so months are across the top of the table.

I'd like to have a grand total at the bottom and even a row total (if possible)

however, all of the 'total' options in the properties are greyed out.

Can anyone advise?

thanks in advance,

Matt

9 Replies
terjeknappen
Partner
Partner

Hi

Have you tried marking "show partial sums" under the Presentation tab?

/Terje

Not applicable
Author

that is greyed out too....

Not applicable
Author

hi,

you can check "show partial sums" for resource name (ie your first dimension) in the presentation tab of your chart properties dialogue



thanks

Not applicable
Author

well I rebuilt the pivot table and was able to select the 'show partial sums' box.

Thank you both for the suggestion - I don't have a clue why it wasn't letting me before...

Not applicable
Author

did you ever resolve this? My pivot tables just changed and greyed out the Show Partial Sums box and I havent a clue why.

Not applicable
Author

On the presentation tab of a pivot, the parital sums options will only be selectable on your dimension fields and not expressions, this makes sense if you think of the dimensions as being the "group by" clause in an aggregation function. A pivot can have many different "groups" as it is expanded and collapsed compared to A straight table which is static.

nathanfurby
Specialist
Specialist

For anyone looking for an answer in the future - I think this may relate to the 'Indent Mode' option on the 'Style' tab of the chart properties.

For some reason the 'Show Partial Sums' option is greyed out when 'Indent Mode' is selected.

FYI - if you need to show a Grand Total in your pivot table and want to display it in indent mode then you first need to uncheck 'Indent Mode' and then select 'Show Partial Sums' on the 'Presentation' tab for your first dimension.  Then go back and select the 'Indent Mode' option.  Seems a bit strange if you ask me.

Not applicable
Author

When I encounter this problem (Expression Total Options Greyed out on a Pivot table) I temporarily change the chart type to Straight Table. I am then able to change the Totals option for all expressions. I then change the chart  type back to Pivot Table.

iktrayanov
Creator III
Creator III

Go to 'Style' tab and uncheck the 'Indent Mode' now  'Show Partial Sums' is not grayed out.