Qlik Community

Ask a Question

QlikView App Dev

Discussion Board for collaboration related to QlikView App Development.

Announcements
Join us at the Cloud Data and Analytics Tour! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

keeping the dimension order the same after selection/filter

I have four charts, and I have an expression for the 4th chart, as follows to avoid filter `Job' being applied to it. =sum({<job=>}Sales). 

TestName      Roomtype    Job     Type1     Type2          Type3          Type4

AN                         large                        1          4                  1              6

BN                         small                      3         1                    1              7

CN                         medium                2            1               5              1

After the filter Job = Type3 is applied, it puts the Type3 column in the very first column for the 4th chart.  Example below in red. How can I have it displayed in ascending order after the filter is applied: example: Type1     Type2      Type 3     Type4

TestName     Roomtype     Job          Type3     Type1          Type2          Type4

1 Solution

Accepted Solutions
Nicole-Smith

Referring to this on your other post:

Monalisa01 said:

So Job is not one of the options that is displayed within sort, so this is what I did, within sort, select any one of the dimensions, in my example above I would select Testname and add expression =job then select ascending order and text (A-Z).

Change that to be =only({1}job) and it will ignore selections.

View solution in original post

5 Replies
Nicole-Smith

Referring to this on your other post:

Monalisa01 said:

So Job is not one of the options that is displayed within sort, so this is what I did, within sort, select any one of the dimensions, in my example above I would select Testname and add expression =job then select ascending order and text (A-Z).

Change that to be =only({1}job) and it will ignore selections.

View solution in original post

Not applicable
Author

Nicole Smith you are the best. Thank you very much, that worked like a charm

Not applicable
Author

Nicole Smith Hello,

Apparently this =only({1}job) works when you first add the expression.  When I come out and save out of it and go back in again, it does not work.  And it also does not work when I publish the dashboard. 

Any ideas.

Nicole-Smith

It should always work (I've used the same thing on many of my dashboards).  If you're seeing something different, you'll need to post a .qvw file.

Preparing examples for Upload - Reduction and Data Scrambling

Not applicable
Author


Seems like it is working now.  Thanks for your prompt response.