Preparing examples for Upload - Reduction and Data Scrambling

    It's frequently useful to upload an example of your application when asking a question on the forum or sharing a technique with other Developers. Two concerns you may have about uploading an example are file size and data privacy.

    Reducing File Size

    The size of your example can be reduced by using the QV File -> Reduce Data command.

    1. Make some selections to reduce the number of possible values in the qvw.
    2. From the menu bar, select File->Reduce Data ->Keep Possible Values.
    3. Use File->Save As to save the reduced copy under a new name

    If you use "Save", QV will still open the "Save As" dialog to help you remember not to overwrite the master copy.

    Protecting Data Privacy

     

    You can protect the privacy of sensitive information, such as account numbers, revenue or customer names by using the QV Scrambling feature. In the menu bar, select Settings->Document Properties->Scrambling.

    Here you can select the field(s) to scramble and press the "Scramble" button to perform a random scrambling of the field . No one can determine it's original contents. Like values will scramble to the same value which maintains the value linkages.