Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
adarsh_a
New Contributor III

Need help in retrieving data from Rigor using Restful connector

Hi All,

I'm trying to create a New Test in Rigor using Restful connector through Qlikview. In Rigor webpage, Test Id is getting created but the id is not retrieved in Qlikview. Below are the steps I'm following :

1.

Rest1img.PNG

Rest2img.PNG

2. When I click on 'Ok' , a connection string is generated.

CUSTOM CONNECT TO "Provider=QvRestConnector.exe;url=https://optimization-api.rigor.com/v2/tests;timeout=30;method=POST;requestBody={

  %3name%3: %3Test_Demo_03%3,

  %3scan_type%3: %3WebPage%3,

  %3start_url%3: %3http://rigor.com%3,

  %3device_type%3: %3DesktopChrome%3

};autoDetectResponseType=true;keyGenerationStrategy=0;useWindowsAuthentication=false;useCertificate=No;certificateStoreLocation=CurrentUser;certificateStoreName=My;queryHeaders=Content-Type%2application/json%1Accept%2application/json%1API-KEY%value;PaginationType=None;XUserId=;XPassword=;";

3. When i Click on Select button to load data, I'm getting below error

Rest3img.PNG

Note:1.  I have checked that the connection has created a test id in Rigor webpage.

        2.  I cannot use the same connection string by changing the 'test name' as the connection string still refers to old connection and gives the same error.

       

Rigor API's link : API Explorer - Rigor Optimization

Any idea to fix this issue is greatly appreciated.


Regards,

Adarsh