Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
awhitfield
Esteemed Contributor

LEF has FORCE_AUTHENTICATION;YES;; BUT Allow Anomymous IS Allowed

When have a client with a new 2012 server With QV 11.2 SR 13, that we are having great trouble getting Licence Leasing to Work on, with the following:

A call was raised with Qlik who advised:

 

We have confirmation from Qlik Support, in addition to the 2 registry keys, read / write access also needs to be granted to the following folders:

 

 

1. C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys

 

2. C:\Users\USERNAME\AppData\Local\QlikTech

 

3. C:\Users\USERNAME\AppData\Roaming\QlikTech

This has not made any difference! Port 4747 is open on the server, the user has full access to the single qvw

HOWEVER , I have just spotted that the LEF file has FORCE_AUTHENTICATION;YES;; (SBE licence) BUT  the client Authentication on the Secuity TAB was Set to ALLOW ANOMYMOUS, surely this is not allowed.

If I use the same licence details on my test rig, I get the expected error:

I DONT GET THE WARNING ON THE WINDOWS 2012, it allows the invalid setting to be saved!

Driving me crazy, is this a bug!

Any ideas etc please?

Andy

 

2 Replies
awhitfield
Esteemed Contributor

Re: LEF has FORCE_AUTHENTICATION;YES;; BUT Allow Anomymous IS Allowed

Screen Shots have gone, arghh!!

awhitfield
Esteemed Contributor

Re: LEF has FORCE_AUTHENTICATION;YES;; BUT Allow Anomymous IS Allowed

Set the server setting to prohibit anonymous, still the same error on desktop. Advised client to browse to qvp://servername/ rather than full domainname, open in server applet open and managed to lease licence.

Any ideas?

Community Browser