Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

QlikView WebServer over https - default port

Hi All,

I'm trying to configure QlikView Web Sevrer to work over https. I've followed instructions from QlikView Server Reference, and I have AccessPoint working with my network alias https://<alias>:433/QlikView/Index.Htm, however I have to use port 443 instead of 433. Every time when I'm trying to change port, either in QVWS config.xml or in QEMC, it doesn't seem to accept my new settings. What's interesting - when I'm using 433, I see processes listening both on 443 and 433. When QVWS is down, neither 443 nor 433 is used. Any ideas?

C:\ProgramData\QlikTech\WebServer>netstat -o -n -a | findstr 43

  TCP    0.0.0.0:433            0.0.0.0:0              LISTENING       4

  TCP    0.0.0.0:443            0.0.0.0:0              LISTENING       4

Thanks,

Lukasz

6 Replies
MVP
MVP

Re: QlikView WebServer over https - default port

Hi Lukasz,

Try stopping QlikView Services, going to the config.xml file in C:\ProgramData\QlikTech\WebServer and make sure that there is only one line like the following:

<DefaultUrl>https://_:443/</DefaultUrl>

Restart the services and see whether the QMC is showing the check in secure communication using https and port is 443. Check with netstat again and only port 443 should be listening. Otherwise, there is some other line in the config file (or in some other config file) that is setting the port 433 to listen.

Hope that helps.

Miguel

Not applicable

QlikView WebServer over https - default port

Hi Miguel,

Thank you for reply. I have only one DefaultURL entry in my config.xml. When I'm changing port to 443 and restarting QVWS, I can see new settings QEMC (443 and use https set), I see process listening only on 443, but unfortunately AccessPoint is no longer working.

I have no single entry pointing to 433 in config.xml file.

Regards,

Lukasz

MVP
MVP

QlikView WebServer over https - default port

Hi Lukasz,

I'm assuming that if you are using HTTPS you have a server certificate in order to make it work aren't you?

Miguel

Not applicable

QlikView WebServer over https - default port

Correct assumption Miguel Https works well on 433, I just can't make it working on default 443 port.

Regards,

Lukasz

MVP
MVP

QlikView WebServer over https - default port

Hi Lukasz,

Does the certificate have the name of the server and the port as well? I mean, do you have re-created the certificate for the new site (using port 443 instead)? Try doing that and try to connect. For some reason, the browser is not detecting that this site has a certificate, and therefore stops the connection.

Hope that helps.

Miguel

Not applicable

QlikView WebServer over https - default port

Hi Manuel,

I used existing certificate, but changed port to which it's bound. Works now. Many thanks for help!

Lukasz

Community Browser