Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

QlikView and MS Access problem

Hi,

I am having an issue with QlikView and Access. I have a administration system in ms access which is used to manage models and users, especially email addresses so I can easily create email distribution lists for each model. I have forced the 32bit connection (connect32) and even converted the access database from accdb to mdb. This enabled me to create the oledb connection which works perfectly and when I reload from within the model I have no issues at all.

My problem comes in when I try reload the model through the Managment Console, it keeps failing??? If I take out code connecting to Access it works fine.

1 Solution

Accepted Solutions
Not applicable

Re: QlikView and MS Access problem

Solved this by upgrading to QlikView 10, apparently an issue with QV 9 and the OLEDB CONNECT 32.

3 Replies
danielrozental
Honored Contributor II

QlikView and MS Access problem

Probably the user running QlikView Distribution Service doesn't have access to the access database

Not applicable

QlikView and MS Access problem

The email addresses are being pulled from the access database into a qlikview variable which is then being used in the  'Alert' function on a post reload trigger to populate the mail recipients. The database is stored on the qlikview server Data folder and all administrators have access to the folder and file.

/*OLEDB CONNECT32 TO [Provider=Microsoft.Jet.OLEDB.4.0;User ID=Admin;Data Source=\\qlikview-01\qlikview\QVData\Data\QlikViewModelOverview.mdb;Mode=Share Deny None;Extended Properties="";Jet OLEDBSmiley Frustratedystem database="";Jet OLEDB:Registry Path="";Jet OLEDBSmiley Very Happyatabase Password="";Jet OLEDB:Engine Type=5;Jet OLEDBSmiley Very Happyatabase Locking Mode=1;Jet OLEDB:Global Partial Bulk Ops=2;Jet OLEDB:Global Bulk Transactions=1;Jet OLEDB:New Database Password="";Jet OLEDB:Create System Database=False;Jet OLEDB:Encrypt Database=False;Jet OLEDBSmiley Very Happyon't Copy Locale on Compact=False;Jet OLEDB:Compact Without Replica Repair=False;Jet OLEDBSmiley FrustratedFP=False];

tmpDistributionList:

SQL SELECT Email,

    Model As QVModel

FROM `QV_Details`

WHERE Model = 'Stock Analysis';

tmpConcat:

LOAD concat(Email & ';') AS EmailList

RESIDENT tmpDistributionList;

Let vEmailList = fieldvalue('EmailList',1);*/

Not applicable

Re: QlikView and MS Access problem

Solved this by upgrading to QlikView 10, apparently an issue with QV 9 and the OLEDB CONNECT 32.