Qlik Community

QlikView Scripting

Discussion Board for collaboration on QlikView Scripting.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

aushikmakdoom
Not applicable

Reading data for CSV generates ',' for last column

Dear All,

I am trying to load data from a CSV file that has 6 columns. When I look at the File Wizard, the last column has a comma (',') appended to the column title as well as all the column values. This happens only to the last column.

Even if I trying changing the Characterset to UTF-8 or other format, the commas are still present.

I do not see these commas in the source CSV file. Can someone let me know why these commas do occur in the data when they are absent in source data ?

Tags (3)
3 Replies
Gysbert_Wassenaar
Not applicable

Re: Reading data for CSV generates ',' for last column

Can you post the csv file? Or a file that contains some lines from it?

If all fails you could always remove the last comma with one of these options:

purgechar(MyField, ',') as MyField

left(MyField,len(MyField)-1) as MyField

subfield(MyField, ',' ,-1) as MyField


talk is cheap, supply exceeds demand
Peter_Cammaert
Not applicable

Re: Reading data for CSV generates ',' for last column

Can you post part of the original CSV?

The import uses semicolons as separators, so I would think that the comma's are present in your input data...

awhitfield
Not applicable

Re: Reading data for CSV generates ',' for last column

From the screen shot it  you have 'Delimiter' set as semi colon ; when it should be comma ,

Andy