2 Replies Latest reply: Sep 6, 2014 1:14 PM by Danial McDonald RSS

    Section Access Error with Multiple OMITs

      Hi,

       

      I am new to QlikView, and completely self taught so far, so please bear with me. I am attempting to apply section access to my dashboard with potentially multiple fields OMITed. Below is a sample of the script I'm using:

       

      Section Access;
      LOAD * INLINE [
      ACCESS, NTNAME, OMIT
      ADMIN, DOMAIN\USER1, FIELD1
      ADMIN, DOMAIN\USER1, FIELD2
      ]
      ;

      Section Application;

       

      This script works just fine when I need to OMIT either FIELD1 or FIELD2, but when I need to OMIT both the user receives an error that the document failed to load as if they do not have access at all.

       

      Based on a similar post: http://community.qlik.com/thread/46242 this should be working. I would appreciate it if anyone could shine some light on this for me.

        • Re: Section Access Error with Multiple OMITs
          Daniel Oberbillig

          Did you try to replace the fields with some other (simple) fields...just to see if the problem is related to the specific fields in the data model or rather a general syntax/system/app related issue.

            • Re: Section Access Error with Multiple OMITs

              Thank you for your reply Daniel Oberbillig.

               

              I attempted to recreate the error with sample data so I could publish it here. Unfortunately I was not able to recreate it with the sample data, so there is nothing wrong with the script itself.

               

              I was going through every setting, formula and object on my dashboard looking for any inconsistencies and finally found 1... I am using a hideprefix to prevent some selections from being displayed in the Current Selections object. After saving the dashboard, the fields containing the hideprefix would no longer be available when the dashboard was reopened.

               

              I promoted the tab containing the data islands with the hideprfix to the beginning of my script and the problem seems to be solved now. I appreciate your help!