7 Replies Latest reply: Dec 5, 2016 1:43 PM by Sravan Katuri RSS

    Unable to delete a report in NPrinting 17.1

    William Rose

      I have created a report previously in QlikView NPrinting 17.1, but now cannot delete it.

       

      When I try to delete it I get a message saying "The user does not have the required rights to perform this action. Contact an administrator.".

       

      This happens even though I am logged in as an administrator, and I can create and delete other reports in the same application. I have also tried logging in using the NPrinting administrator account set up during install, with the same error reported.

       

      I have also tried just deleting the whole app (it was a testing app). There are some published reports in the News Stand, but there doesn't seem to be a way to delete those.

       

      The log files record the access denied error but don't provide hints for a remedy.

      Qlik.NPrinting.Repo     17.1.0.0     Qlik.NPrinting.Repo.Service.SessionManager     20160810T134551.117-04:00     ERROR     MYHOSTNAME     william_rose     0     0     0     0     0     0     0     0     Error within WithSession method of SessionManager.          
      Qlik.NPrinting.Repo     17.1.0.0     Qlik.NPrinting.Repo.Service.SessionManager     20160810T134551.117-04:00     ERROR     MYHOSTNAME          william_rose     0     0     0     0     0     0     0     0     Access denied          
      Qlik.NPrinting.WebEngine     17.1.0.0     Qlik.NPrinting.WebEngine.Controllers.HttpHelper     20160810T134551.119-04:00     ERROR     MYHOSTNAME          william_rose     0     0     0     0     0     0     0     0     Security exception serving the request http://myhostname.mycompany.com:4996/npe/reports/eba487c7-b2db-4534-8d3a-b83f34ee64ac?count=10&orderBy=title&page=1     Access denied     ↵↓=============↵↓      _printStack↵↓      Error↵↓      WithErrorHandling↵↓      Delete↵↓      Delete↵↓      lambda_method↵↓      b__9↵↓      ExecuteAsync↵↓      MoveNext↵↓      Start↵↓      InvokeActionAsyncCore↵↓      InvokeActionAsync↵↓      b__0↵↓      b__f↵↓      ExecuteActionFilterAsync↵↓      b__9↵↓      MoveNext↵↓      Start↵↓      ExecuteAsync↵↓      b__0↵↓      MoveNext↵↓      Start↵↓      ExecuteAuthorizationFilterAsyncCore↵↓      b__2↵↓      MoveNext↵↓      Start↵↓      ExecuteAuthorizationFilterAsyncCore↵↓      b__2↵↓      ExecuteAsync↵↓      MoveNext↵↓      Start↵↓      SendAsync↵↓      SendAsync↵↓      SendAsync↵↓      SendAsync↵↓      SendAsync↵↓      MoveNext↵↓      Start↵↓      SendAsync↵↓      MoveNext↵↓      Start↵↓      SendAsync↵↓      MoveNext↵↓      Start↵↓      ProcessRequestContext↵↓      ReceiveRequestContextComplete↵↓      Complete↵↓      Set↵↓      EnqueueAndDispatch↵↓      EnqueueAndDispatch↵↓      Enqueue↵↓      CompleteParseAndEnqueue↵↓      HandleParseIncomingMessage↵↓      SyncContinue↵↓      BeginProcessInboundRequest↵↓      ProcessHttpContextAsync↵↓      BeginHttpContextReceived↵↓      EnqueueContext↵↓      OnGetContextCore↵↓      UnhandledExceptionFrame↵↓      Complete↵↓      IOCompleted↵↓      PerformIOCompletionCallback↵↓↵↓=============↵↓
      

       

      I'm not sure what to try next - has anyone experienced this before?

        • Re: Unable to delete a report in NPrinting 17.1
          Daniel Jenkins

          Hi William,

           

          It appears that the Role assigned to user william_rose does not have Delete rights on Reports.

           

          To check or edit this, log into the NPrinting web console as an NPrinting administrator, make a note of the Role assigned to william_rose (Admin > Users > william_rose > Roles). Now check the permissions for that role (Admin > Security roles > [select the role]). https://help.qlik.com/en-US/nprinting/17.1/Content/Security/ManageSecurity/Security-management.htm

           

           

          HTH - Daniel.

            • Re: Unable to delete a report in NPrinting 17.1
              William Rose

              Thanks Daniel!

               

              I had already assigned my user account the built-in Administrator role which includes all permissions, including the report deletion privilege.

               

              Nonetheless I created a new role, configured it to have all privileges, including Report > Delete, assigned that role to my user account, logged out and logged in again, and tried to delete the report once more.

               

              I get the same result, which makes me think this is not actually due to a permissions issue.

                • Re: Unable to delete a report in NPrinting 17.1
                  William Rose

                  I switched on statement logging in Postgres in the repository, and it executes the queries at the bottom of the email when I try to delete.

                   

                  The penultimate statement seems to check the permissions for my user account - if I re-run this statement it returns 1 indicating that I have the report delete permission.

                   

                  In the final statement the results that are returned include a row marked WaitingForRetry, though the dates are all from a couple of weeks ago. But possibly the system is stuck because a scheduled task is yet to run or some other aspect of the system is failing and it is detected as a permissions violation. I can't see a way in the UI to remove or cancel any pending jobs, though, so I don't know how to clear this up.

                   

                  Here are the queries - after the last statement the log indicates a rollback of the batch, in contrast to other cases where the batch is committed:

                   

                  SELECT report0_.id                   AS Id47_0_,
                         report0_.version              AS Version47_0_,
                         report0_.created              AS created47_0_,
                         report0_.last_update          AS last4_47_0_,
                         report0_.report_type_id       AS report5_47_0_,
                         report0_.title                AS title47_0_,
                         report0_.description          AS descript7_47_0_,
                         report0_.original_ref         AS original8_47_0_,
                         report0_.enabled              AS enabled47_0_,
                         report0_.deleted              AS deleted47_0_,
                         report0_.on_demand_enabled    AS on11_47_0_,
                         report0_.template_format      AS template12_47_0_,
                         report0_.entities_xml         AS entities13_47_0_,
                         report0_.template_tree        AS template14_47_0_,
                         report0_.has_dynamic_name     AS has15_47_0_,
                         report0_.app_id               AS app16_47_0_,
                         report0_.qlik_view_entity_id  AS qlik17_47_0_,
                         report0_.import_task_id       AS import18_47_0_,
                         report0_.template_file_id     AS template19_47_0_,
                         report0_.variable_sequence_id AS variable20_47_0_
                  FROM   report report0_
                  WHERE  report0_.id = ( ( 'eba487c7-b2db-4534-8d3a-b83f34ee64ac' ) :: uuid )
                  
                  SELECT Count(*) AS y0_
                  FROM   vw_resolved_app_permission this_
                  WHERE  this_.user_id = ( ( 'cea4a9a0-9408-4716-bb0b-1372da8fd404' ) :: uuid )
                         AND this_.app_id = ( ( 'f332f060-e2ba-450a-8760-f09b9b341651' ) :: uuid )
                         AND this_.action_section = ( ( 'Report' ) :: text )
                         AND this_.action_name = ( ( 'View' ) :: text )
                  
                  SELECT app0_.id                    AS Id4_0_,
                         app0_.version               AS Version4_0_,
                         app0_.name                  AS name4_0_,
                         app0_.description           AS descript4_4_0_,
                         app0_.created               AS created4_0_,
                         app0_.last_update           AS last6_4_0_,
                         app0_.enabled               AS enabled4_0_,
                         app0_.smtp_configuration_id AS smtp8_4_0_
                  FROM   app app0_
                  WHERE  app0_.id = ( ( 'f332f060-e2ba-450a-8760-f09b9b341651' ) :: uuid )
                  
                  SELECT dataconnec0_.app_id                    AS app13_1_,
                         dataconnec0_.id                        AS Id1_,
                         dataconnec0_.id                        AS Id12_0_,
                         dataconnec0_.version                   AS Version12_0_,
                         dataconnec0_.created                   AS created12_0_,
                         dataconnec0_.last_update               AS last4_12_0_,
                         dataconnec0_.name                      AS name12_0_,
                         dataconnec0_.description               AS descript6_12_0_,
                         dataconnec0_.connection_string         AS connection7_12_0_,
                         dataconnec0_.apply_user_session_access AS apply8_12_0_,
                         dataconnec0_.cache_status              AS cache9_12_0_,
                         dataconnec0_.connection_status         AS connection10_12_0_,
                         dataconnec0_.last_cache_update         AS last11_12_0_,
                         dataconnec0_.status_description        AS status12_12_0_,
                         dataconnec0_.app_id                    AS app13_12_0_,
                         dataconnec0_.cache_task_id             AS cache14_12_0_,
                         dataconnec0_.cache_file_id             AS cache15_12_0_
                  FROM   data_connection dataconnec0_
                  WHERE  dataconnec0_.app_id = (
                         ( 'f332f060-e2ba-450a-8760-f09b9b341651' ) :: uuid )
                  
                  SELECT Count(*) AS y0_
                  FROM   vw_resolved_app_permission this_
                  WHERE  this_.user_id = ( ( 'cea4a9a0-9408-4716-bb0b-1372da8fd404' ) :: uuid )
                         AND this_.app_id = ( ( 'f332f060-e2ba-450a-8760-f09b9b341651' ) :: uuid )
                         AND this_.action_section = ( ( 'Report' ) :: text )
                         AND this_.action_name = ( ( 'Delete' ) :: text )
                  
                  SELECT this_.id                  AS Id35_0_,
                         this_.created             AS created35_0_,
                         this_.type                AS type35_0_,
                         this_.title               AS title35_0_,
                         this_.downloaded          AS downloaded35_0_,
                         this_.status              AS status35_0_,
                         this_.output_format       AS output7_35_0_,
                         this_.error_code          AS error8_35_0_,
                         this_.error_message       AS error9_35_0_,
                         this_.request_source_type AS request10_35_0_,
                         this_.user_id             AS user11_35_0_,
                         this_.report_id           AS report12_35_0_,
                         this_.response_file_id    AS response13_35_0_
                  FROM   on_demand_request this_
                  WHERE  this_.report_id = ( ( 'eba487c7-b2db-4534-8d3a-b83f34ee64ac' ) :: uuid )
                  • Re: Unable to delete a report in NPrinting 17.1
                    Daniel Jenkins

                    Hi William,

                     

                    What happens if you log into NPrinting as the administrator account you created while installing it?

                     

                    - Daniel.

                • Re: Unable to delete a report in NPrinting 17.1
                  Sravan Katuri

                  Hi All,

                  unable to delete a report is a bug. please upgrade the version 17.2.1. below is the bug fix in 17.2.1. I had this issue with document without on-demand also after upgrade I can delete it now..!!

                   

                   

                  del report.PNG

                  Thanks

                  sravan