Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Anonymous
Not applicable

Jira Web Connector: Could not save connector table parameters

Hi everyone,

I'm having the following problem with the Jira Web Connector.

The error message is: Could not save connector table parameters. Status code = 500.

jira.png

Any advice on how to solve it?

Thanks

1 Solution

Accepted Solutions
stevedark
Partner Ambassador/MVP
Partner Ambassador/MVP

I've not encountered this issue myself, but I would check that the service account that QWC is running under has full write permissions to the QWC folder. A number of items are cached in the folder when you set parameters.

Hope that helps.

View solution in original post

3 Replies
dmitri_volkov
Contributor III
Contributor III

I have the same problem with SMTP connector.

Logged error is 

<LogEntry version="1.0.3">
        <Id>b9b0e46f-0baf-4b64-8696-17ac5b0d2656_75</Id>
        <Datetime>14-01-2019 16:24:30.99</Datetime>
        <Type>Error</Type>
        <Sender>APIConnectorWeb.Nancy.Modules.WebAPIAuth</Sender>
        <ServerMode>true</ServerMode>
        <Version>2.49.4.29415</Version>
        <Message>Could not save connector table parameters.</Message>
        <Exception>System.UnauthorizedAccessException: Access to the path 'c:\QlikWebConnectors\App_Data\DEFAULT0-0000-0000-0000-000000000000\ConnectorSettings.xml' is denied.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
   at APIConnectorEngine.Qwc.XmlFileSettingsStorerGeneric.SaveSettings(ConfigSettings settings)
   at APIConnectorEngine.Qwc.XmlFileSettingsStorerWithMutex.RunLocked(Action action)
   at APIConnectorWeb.Nancy.Modules.WebAPIAuth.&lt;&gt;c__DisplayClass3_0.&lt;.ctor&gt;b__18(Object x)</Exception>
        <ExceptionMessage>Access to the path 'c:\QlikWebConnectors\App_Data\DEFAULT0-0000-0000-0000-000000000000\ConnectorSettings.xml' is denied.</ExceptionMessage>
        <AdditionalInfo>
            <UserIP>::1</UserIP>
            <User>Admin (Default)</User>
        </AdditionalInfo>
    </LogEntry>

 In deploy.config I have

<FileSystemAccessAllowedPaths> c:\temp;c:\QlikWebConnectors</FileSystemAccessAllowedPaths>
stevedark
Partner Ambassador/MVP
Partner Ambassador/MVP

I've not encountered this issue myself, but I would check that the service account that QWC is running under has full write permissions to the QWC folder. A number of items are cached in the folder when you set parameters.

Hope that helps.

Niroopananda
Support
Support

Hi @dmitri_volkov 

This is due to the permissions issue. Try using the service account and make sure you have given the full access to the QWC folder for the service account.