Qlik Community

Ask a Question

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
Qlik Insider - Maximize your investment, Join this webinar, May 26th. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
micahsakata
Contributor III
Contributor III

Qlik Web Connector for a multi node environment

I installed Qlik Web Connectors on my central node in a multi node environment.  I followed the basic instruction and I'm able to set up web connector and run it locally when I'm in my app, using localhost as my server connection.  This is obviously because when I'm running script from the hub, it runs on the central node.  However, when I have the scheduler run this, on a rim node, it fails.  I have 2 issues.

First, I get errors when I try to create a new web file data connection.  If I use the server name for my connection to the web connectors, I get various errors.  For example, my server name is hypothetically "QLKTST01".  When I create the web connection, it fails when I try to add it with the following error message:

  1. http://QLKTST01:5555 - request is invalid
  2. http://localhost:5555 - access is denied
  3. https://QLKTST01.domain.com:5555 - SSL/TSL handshake failed. Certificates and/or passwords are invalid

The only way to make it work is if I create it as "http://localhost:5555/web/".  I get an access is denied error but I can click through it and get results.

Second, what kind of changes do I need to make changes in my deploy.config file?  Do I need to enable "AllowRemoteAccess"?  It's not clear in the documentation if this is for remote access of the rim nodes under the service account.  What I'm reading is that this is for users to access the web connector interface to generate their own script.

Labels (1)
2 Replies
chrisbrain
Specialist II
Specialist II

Hi,

These two issues sound like the same underlying issue to me.

In your first para you say you can create and use a connection successfully using localhost but in the next para you say you are getting 'access denied' - where is this happening from compared to the first para?

From what you say if you need to support reloads from nodes other than where QWC is running then you will need to set AllowRemoteAccess to true and I would also say set up forms auth users for the web interface and require SSL as described here:

https://help.qlik.com/en-US/connectors/Subsystems/Web_Connectors_help/Content/Connectors_QWC/Adminis...

With AllowRemoteAccess = true by default QWC should listen on the machine name so I would expect version 1. in your list below to work. But I would recommend ensuring you can ping this from the machine(s) where you need to connect from and if this doesn't work you could use the HostnameOverride setting in deploy.config to set e.g. your 3. value above.

Francisco_Fernandez

Hello @micahsakata ,

I would suggest checking in the deploy.config file if the following tags:

<AllowRemoteAccess>true</AllowRemoteAccess>
<DefaultAllowedIpAddresses>any</DefaultAllowedIpAddresses> (It can be any IP that you want to use but I suggest using any for testing purposes.)


And also that you have the same allowed Ip addresses in the UI. (make sure to press save if you make any change)

Francisco_Fernandez_0-1616420675424.png