Qlik Community

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Don't miss the upcoming Q&A with Qlik session on Qlik Application Automation on November 16th! REGISTER NOW
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

STORE Command Additional Double Quotes

hi all,

Whenever i have a line containing a single quote in the text of a resident table,

On using a STORE INTO filename.txt(txt)  it gets wrapped by an additional double quote at the start and end .

How do i get rid of this additional double quote ?

I  have already used windows powershell to get over this double quotes

however when there are 2.4 million records having single quotes it takes 6 hours to remove the double quotes from the text and write to a new file.

I am looking at an option where the double quotes are not appended when storing into text file from Qlikview


LOAD DummyCommit AS '--Insert_Statement' INLINE



Expected Output:


Labels (3)
2 Replies
Contributor II
Contributor II

@Darren_Ball ,

Any inputs on the above query?

Specialist II
Specialist II

I think this might be the expected behaviour, e.g. reading this:


It suggests that it is common behaviour when writing a CSV file to wrap any strings which contain 'special characters' in quotes to avoid confusing other systems which may read them.

This probably doesn't help you and I would be happy to be proven wrong and that there is a solution here.

Is this causing you an issue for reading these files into other downstream systems or are you having trouble loading them back into Qlik (in which case maybe you could try 'qvd' instead of 'txt' as the format?).

The only less than ideal workaround I could suggest is using the replace function to either remove the apostrophe or replace it with something else e.g. `.