Skip to main content
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

Sql Server Connection

Hi All,

I am using Qlik Sense Cloud and I want to extract data using SQL Server, hence Qlik Cloud cant support ODBC and OLEDB connectors for SQL Server.

I use SQL Server Connector which is available in Qlik Sense Cloud when I create a connection it generates the error of username password and host.

My SQL Server is log in with windows authentication.

Kindly help me out.


Kindly Regards


Labels (2)
3 Replies
Partner Ambassador/MVP
Partner Ambassador/MVP

Hi @aghabdurauf 

I don't think you will be able to use a Windows login to your SQL Server, as the Qlik Cloud instance is not on the domain of your SQL Server.

Suggest setting up a new user, with username and password access, and giving that uesr very limited access to the database - just to the area you want to load into Sense.

You will need to put your SQL Server into mixed mode authentication to do this. This may cause issues for your DBAs. If this is the case you may need to find another route for getting the data into Qlik Cloud.

Hope that helps.


Partner - Contributor II
Partner - Contributor II

Hi @aghabdurauf  

I' m not an exprert but i think u need to use Qlik Data Transfer, install on ur SQL Server and make the connection and set wich app on Cloud to be refresh after extracction.

0 ) Install Qlik Data Transfer

1) You can create ODBC to ur SQL Server

2) You can create Qvf app using ODBC to extract all tables u need

3) Config into Qlik Data Transfer to execute Qvf app, ather this you can set witch app in the Qilk Sense Business (SaaS) want to update and this data will be upload to this app into Data "Files Folder" like qvd's files

4) now you need to update  the sources into your app.( to use this qvd's)

I hope this info can help you

Partner Ambassador/MVP
Partner Ambassador/MVP

This looks quite neat. I need to give it a try. Thanks for sharing @Benito_Sanchez