Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
cancel
Showing results for 
Search instead for 
Did you mean: 
itamarbiot
Contributor
Contributor

400 "The http request header is incorrect" access from remote machine

I have set up a new Qlik deployment on AWS.

After setup when I click on QMC on the local machine I get to the enter license screen.

As I'm doing this as a service for another company I have set up a remote connection and opened the proper ports.

When I browse to the Qlik server from a remote machine I get to a Qlik error page saying "400- The http request header is incorrect."

From the fact that I get a Qlik error, I can understand that the ports are opened properly but I don't understand what else should be set up or what is missing from the setup.

Labels (3)
1 Solution

Accepted Solutions
faseevqubdata
Partner
Partner

The address being used when accessing Qlik Sense from a remote machine must be added to the Host White List in the virtual proxy.

You can do it after licensing Qlik.

View solution in original post

6 Replies
faseevqubdata
Partner
Partner

The address being used when accessing Qlik Sense from a remote machine must be added to the Host White List in the virtual proxy.

You can do it after licensing Qlik.

View solution in original post

ruisilvafilipe
Contributor
Contributor

Hello,

I have a similar problem, and already added all the adresses in the whitelist.

I have following set-up:  Browser - 443 - Load Balancer - 80 - instance. 

As mention, QlikSense is reachable, but there is something which are blocking. Also allowed the http port..

 

morenoju
Partner
Partner

Same problem for me. I added the internal and external IP and the hostname. Still Error 400...

sudhirpkuwar
Partner
Partner

Hi,

I am facing the same problem and already added all the adresses in the whitelist.

Any solution to this ?

 

rizwaanadil
Contributor
Contributor

I have already added all the possible values in the whitelist. Still getting the 400 error. Any updates?

sudhirpkuwar
Partner
Partner

Hi Rizwaanadil,

 

In the host whitelist you have to add only 3 things:

1. The public ip address without http or https.

2. The domain name with https or http.

3. The domain name without https or https.

As shown in image below:

 

Thanks and regards,

Sudhir