Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
vighnesh2022
Partner - Contributor III
Partner - Contributor III

Data Connections in Qlik Sense Hub not loading

Hi Guys,

 My setup is  Windows server where Qlik sense (May 2023) is, has internet access and we need to connect to Company's VPN to access Qlik sense server.

PFA, I am getting this error while I opened Data load editor each time. It takes 5-10 minutes to load data connections and after that some connections doesn't appear eg. OneDrive, GDrive etc.

I tried solutions from these articles.

https://community.qlik.com/t5/Official-Support-Articles/Data-Connections-Pane-in-Qlik-Sense-Hub-not-...

https://community.qlik.com/t5/Official-Support-Articles/An-error-occurred-Failed-to-load-connection-...

 

 

but still error doesn't  resolved. Data connections keep loading very slowly.

 

Is there any other workaround this ? Thanks

Labels (2)
1 Solution

Accepted Solutions
vighnesh2022
Partner - Contributor III
Partner - Contributor III
Author

So I found solution. Because connections are not working. I need to recreate encryption key for those connectors.

more info on below article.

https://community.qlik.com/t5/Official-Support-Articles/Qlik-Sense-Enterprise-on-Windows-Error-retri...

View solution in original post

6 Replies
HeshamKhja1
Partner - Creator II
Partner - Creator II

Hi @vighnesh2022 ,

This might be because one or more connections are taking too long to be functional that they are causing the data connections to take too long.

If you connect to Qlik Sense from the localhost (from server directly), do you get the same issue?

If yes, then it is not related to the VPN and you better check the connections created and see which one is causing the issue.

vighnesh2022
Partner - Contributor III
Partner - Contributor III
Author

Hi @HeshamKhja1 ,

   thanks for response. 

  I just checked with localhost , And yes I still get same issue.  

>>  If yes, then it is not related to the VPN and you better check the connections created and see which one is causing the issue.

How do I check this?

 

edit:

also certain connectors are not visible while loading is finish. eg. Onedrive, GDrive etc.

HeshamKhja1
Partner - Creator II
Partner - Creator II

If any of the data connection show errors then these are the first to look at.

also as you mentioned 


also certain connectors are not visible while loading is finish. eg. Onedrive, GDrive etc.


then maybe these are the connections that are causing the issue.

If you are root admin, then make sure you have access to these connections, then see if they are functional. Try to recreate them and see what errors you get.

Additionally, check the logs of the connectors. You can find the paths here: https://community.qlik.com/t5/Qlik-Fix/Qlik-Fix-How-to-Find-Qlik-Connector-Logs/ta-p/1762915

See what errors they are giving.

vighnesh2022
Partner - Contributor III
Partner - Contributor III
Author

Hi,  

  I checked connectors log. 

  I am seeing below error log in both WebConnectorPackage and WebConnectorStorageProviderPackage.

Not sure how to move forward from this:

30 Oct 2023 16:44:44,365 [1] - INFO - PipeName=command_2d9f7100067aec4cbe251763474f2896204b412c Source=QWC ReloadId=NA TenantId=NA UserIdType=NA UserId=NA EngineSessionId=NA AppId=NA RequestGuid=NA ConnectorId=NA Sender=IntegratedConnectorSettings Message=Created IntegratedConnectorSettings from embedded resource.
30 Oct 2023 16:44:44,442 [1] - ERROR - PipeName=command_2d9f7100067aec4cbe251763474f2896204b412c Source=QWC ReloadId=NA TenantId=NA UserIdType=NA UserId=NA EngineSessionId=NA AppId=NA RequestGuid=NA ConnectorId=NA Sender=Program Message=Unhandled exception.
APIConnectorInterfaces.Exceptions.QwcException: Could not get key with id prefix 'qseow_tmp' ---> System.Security.Cryptography.CryptographicException: Key not valid for use in specified state.

at System.Security.Cryptography.ProtectedData.Unprotect(Byte[] encryptedData, Byte[] optionalEntropy, DataProtectionScope scope)
at Qlik.Connectors.WebPackage.Startup.KeyProvider.ReadKey(String keyFilePath, Byte[] entropy)
at Qlik.Connectors.WebPackage.Startup.KeyProvider.GetKeyInternal(Boolean autoCreate)
--- End of inner exception stack trace ---
at Qlik.Connectors.WebPackage.Startup.KeyProvider.GetKeyInternal(Boolean autoCreate)
at QvWebConnectorPackage.Startup.ProductServices_QSEoW.Init(KeyState keyState, Boolean isWebStorageProvider)
at QvWebConnectorPackage.Program.Main(String[] args)

vighnesh2022
Partner - Contributor III
Partner - Contributor III
Author

So I found solution. Because connections are not working. I need to recreate encryption key for those connectors.

more info on below article.

https://community.qlik.com/t5/Official-Support-Articles/Qlik-Sense-Enterprise-on-Windows-Error-retri...

brunoeroliveira
Partner - Contributor II
Partner - Contributor II

If your data connections folder is there, this solution won't work.


In my case, after reseting the service user password, all my connections crashed.


I tried almost everything, read every article but didn't found a solution for my case.


Only when I created another user, give adm rights on windows and changed the services to run with this new adm user it worked for me.

So I'm here to spread the word.