Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
m_perreault
Creator III
Creator III

Load Balancing Consumer Nodes

Hi All,

 

If I have two consumer Rim Nodes are they able to share a URL or must they have two unique URL's (Prefix).  My ideal state is having one URL for users to Navigate to and when they open App A it uses the Engine on Rim Node 1 and when they open App B it uses the Engine on Rim Node 2.  Sending users to different URLs for different apps becomes confusing.

 

Thanks,
Mark

Labels (2)
30 Replies
sujay
Contributor II
Contributor II

Thanks Rohit,

sujay
Contributor II
Contributor II

Thank you so much Rohit,

Regards

Kham,

sujay
Contributor II
Contributor II

Hi Rohit/All,

 

Could you please help us to resolve the issue for the below screenshot error . We have configured the load balancer between 2 RIM node and while accessing the load balancer url , we are getting the below error .  one more point is that if we have all the service are running on both RIM node then sometime it is getting accessed with the same error and sometime it is not and it is throwing "bad network error" 

 

what we observer is  if we have service running on only on one RIM node than it is opening with the below error. 

 

Could someone please help here , appreciate your help in this matter.  

 

hub url error.PNG

sujay
Contributor II
Contributor II

Hi All, 

 

please ignore my previous attachment as it was uploaded the previous one.  uploading the correct one. 

 

Hi Rohit/All,

 

Could you please help us to resolve the issue for the below screenshot error . We have configured the load balancer between 2 RIM node and while accessing the load balancer url , we are getting the below error .  one more point is that if we have all the service are running on both RIM node then sometime it is getting accessed with the same error and sometime it is not and it is throwing "bad network error" 

 

what we observer is  if we have service running on only on one RIM node than it is opening with the below error. 

 

Could someone please help here , appreciate your help in this matter.  

 

lb url.PNG

fatinfazrizanor
Partner
Partner

Hi sir,

Do you achieve the final result? Can you give the guidelines on how to do this?

i also have same case where user need to go to only one domain URL(central node), and when open app A, it will uses Engine Node 1. If open app B, it will uses Engine Node 2.

I have configure the load balancing, but it only be achieve by use unique URLs. 

I'll appreciate if you can help.

 

Thank you.

rohitk1609
Specialist III
Specialist III

This error usually comes due to network connectivity breaks especially where user needs to connect to company's VPN to access Qlik. When Qlik link is mapped to public IP, there also it occurs but rare once in couple of hours.

If you take RDP and open the Qlik Sense through load balancer link, do you see this issue? Does this issue occur from first second of hub opening or after a certain time it occurs?

 

Thanks,

Rohit

 

rohitk1609
Specialist III
Specialist III

i also have same case where user need to go to only one domain URL(central node), and when open app A, it will uses Engine Node 1. If open app B, it will uses Engine Node 2.

This case is that you haven't configured your virtual proxy settings properly. If you have two consumer or proxy nodes, Go to QMC=> virtual proxies= consumer or proxy 1 => load balancing=> add consumer 1 and consumer 2

do the same for consumer 2 virtual proxy.

After it, App will be served by such engine which is best available(it uses round robin algo to choose which app will be server by which engine)

 

Thanks,

Rohit

fatinfazrizanor
Partner
Partner

Hi Rohit, thank you for your replied.

I've add both nodes in load balancing for both consumer nodes. But the stream still open using central nodes. 

Do i need add load balancing in central proxy also?

 

Thanks.

 

rohitk1609
Specialist III
Specialist III

Don't add consume nodes virtual proxy in load balancing section of central virtual proxy.

Please remove central virtual proxy from load balancing section of both consumer nodes. 

Open or access app by using consumer or proxy server link. if you use central proxy serve of course app will be served  by central server.

 

If a post helps to resolve your issue, please mark the appropriate replies as "Accept as Solution" or Like it.
Best,
Rohit

amitghaste
Contributor II
Contributor II

I know this might be a bit of a late  to responding back, but let me lay this out for you.

The proxy is where the HTTP requests get processed, the Virtual Proxy acts as a web front to the same.

The servers in the Load Balancing section are the ones providing the engines to the Virtual Proxy. 

So you can have 

User--> [Proxy Server/central] ->->[Consumer Node 1][Consumer Node 2]

The proxy will act as a round robin loading apps from the Rims, depending on multiple factors including if an app is already loaded in a consumer node , available RAM/CPU etc.,

in the above scenario, there is only a single "URL" so to speak which is pointing to the Central in the above flow, all the user's requests will always pass through the proxy server, it never hits the consumer nodes, unless you set them up as a proxy. as well.

------

A much more complex setup:

USER -> [DNS server] -> F5 -> Qlik Proxy 1, Qlik Proxy 2 -> Consumer Node 1 to n  

In the above case, you have a DNS server with an entry like qlik.mycompany.int which points to a F5 entry, the F5 (note this will have to have a Sticky session profile built in it, cause that is a requirement from Qlik), will then act as a round robin server for the Qlik proxy servers 1 and 2, and regardless of which proxy it hits, the appropriate consumer nodes will serve up the application back to the user.

Note: here you have to set all the consumer nodes in each of the proxy settings in QMC. 

Edit: you have to remove the central node from the load balancing servers in the virtual proxy, then the central server will not be used as an engine node.