Qlik Community

Ask a Question

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
QlikWorld Online 2021, May 10-12: Our Free, Virtual, Global Event REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
s29124141
Partner
Partner

Load Balancing Engine Node

I am looking for a solution, so that i can configure the apps in Dedicated stream to run only in Dedicated Engine Node. As per default rule, central node runs all the apps. Even if the dedicated engine node is sitting idle, central node is not sending that to that node.

Is there anyway I can run the "DemoStaging" app in dedicate engine node only?

QS Server Version : June 2017

 

StreamAppNode
SharedApp1Central
SharedApp2Central
SharedApp3Central
SharedApp4Central
DedicatedDemoStagingDedicated Engine Node

qmc.png

1 Solution

Accepted Solutions
s29124141
Partner
Partner
Author

Issue seems to be resolved now by itself. It looks like the load balancing rules will not take place when there is active user sessions. Since there was no user activity during this weekend, dedicated app was synced to its own dedicated engine node. Thanks jaikumarsoni and digvijay for your response.

https://help.qlik.com/en-US/sense/3.2/Subsystems/ManagementConsole/Content/add-load-balance.htm

View solution in original post

5 Replies
Digvijay_Singh
Master III
Master III

Tagging experts for help -

dvqlikview

erik.wetterberg

bill.markham

mto

Thanks in advance!!!

jaisoni_trp
Creator II
Creator II

You can write a load balancing rule to load all the apps from Dedicated stream to load on specific Engine. Something like..

Resource Filter: App_*

Condition: ((node.name="Engine" and resource.stream.name="Dedicated"))

Make sure to disable the default rule.

s29124141
Partner
Partner
Author

Thanks for the reply jaikumarsoni‌ I have the load balancing rule in place and I see the rule is valid when I preview/audit the rule. Not sure why the app is still running in central node, instead of dedicated engine node.

jaisoni_trp
Creator II
Creator II

Are you going via correct virtual proxy which has dedicated engine association.

s29124141
Partner
Partner
Author

Issue seems to be resolved now by itself. It looks like the load balancing rules will not take place when there is active user sessions. Since there was no user activity during this weekend, dedicated app was synced to its own dedicated engine node. Thanks jaikumarsoni and digvijay for your response.

https://help.qlik.com/en-US/sense/3.2/Subsystems/ManagementConsole/Content/add-load-balance.htm

View solution in original post