Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 
polyakov
Partner - Contributor III
Partner - Contributor III

Monitoring QSEoW used Zabbix Agent 2

Hi! 

I need monitoring my server QSEoW (now Nov2023 p4) located on Azure with Zabbix Agent2.

QSEoW standart install with any custom settings.

In the plan i wish monitor engine/healthcheck/. 

But i got 401 when i try autheentication.

What else did i notice - this problem only in the azure infrastructure. On AWS and GCP - all ok. 

I want use standart authentification without create aditional Virtual Proxy.

Maybe anybody had problem like this?

Labels (2)
1 Solution

Accepted Solutions
polyakov
Partner - Contributor III
Partner - Contributor III
Author

Hi, 

This answer to my question from support:

Hello Ihor,

As checked with my team, this is working as designed.

It not possible to authenticate on 443 port using the certificates.

View solution in original post

4 Replies
polyakov
Partner - Contributor III
Partner - Contributor III
Author

Hi @Chetan_MN 

Thanks for link. The fact is that I already have several hosts configured for healthcheck monitoring, but they either do not have authentication or are allowed to be anonymous. I'm interested in how to pass NTLM authentication without changing the virtual proxy or adding a new one.

I think my problem in the authentication redirecting to /internal_windows_authentication/.

I tryed set in the config a Data element NTLM Auth and set Login and Pass - but still got 401.

 

polyakov
Partner - Contributor III
Partner - Contributor III
Author

Seems like one way is do NAT for 4747 and uses certificate to auth:

curl -v --cert /home/user/client.pem --key /home/user/client_key.pem --insecure https://qliksense:4747/healthcheck/?xrfkey=0123456789abcdef --header "x-qlik-xrfkey: 0123456789abcdef" --header "User-Agent: Windows" --header "X-Qlik-User: UserDirectory=DOMAIN;UserId=admin1" -L

I would like not to change the settings or open additional ports on the server, but otherwise I won’t be able to pass Windows authentication.

polyakov
Partner - Contributor III
Partner - Contributor III
Author

Hi, 

This answer to my question from support:

Hello Ihor,

As checked with my team, this is working as designed.

It not possible to authenticate on 443 port using the certificates.