Skip to main content

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
Imran_Arshad
Partner - Contributor III
Partner - Contributor III

QSEoK -- Local Cloud

Kind Attn. Qlik Community,

I am facing the following error while installation the qliksense pods to kubernetes environment.

$ helm install -n qliksense qlik/qliksense -f values.yaml
Error: validation failed: [unable to recognize "": no matches for kind "Deployment" in version "extensions/v1beta1", unable to recognize "": no matches for kind "Deployment" in version "apps/v1beta2", unable to recognize "": no matches for kind "StatefulSet" in version "apps/v1beta2"]

 

Need expert opinion to get the exact solution.

Regards,

Imran

 

 

 

Labels (1)
  • SaaS

7 Replies
ThiebaudS
Partner - Creator II
Partner - Creator II

Hi there,

I would say it's probably a syntax error in your values.yaml ?

vinicius_rosa
Partner - Contributor III
Partner - Contributor III

Look your helm version: 2.16

And check system requirements:

https://help.qlik.com/en-US/sense-admin/November2019/Subsystems/DeployAdministerQSE/Content/Sense_De...

Kubernetes package manager Helm greater than v2.12.0 and less than v2.15.x

I recomended version 2.13 its work for me.

celindho
Partner - Creator
Partner - Creator

Hi,

I'm getting this same error when trying to install a testing environment on my Mac: 

  • Docker Desktop 2.3.0.2 (Kubernetes v.1.16.5)
  • Helm v2.14.3 (both Client and Server)

Were you able to solve the problem? What helped in solving the issue?

BR,

-Christian

vinicius_rosa
Partner - Contributor III
Partner - Contributor III

So, in my case change the helm version solved my issue.

 

Try this script:

 

wget https://get.helm.sh/helm-v2.15.1-linux-amd64.tar.gz
tar xvfz helm-v2.15.1-linux-amd64.tar.gz
cd linux-amd64
cp -f tiller helm /usr/local/bin
helm init

stein_to
Partner - Contributor II
Partner - Contributor II

<< Were you able to solve the problem? What helped in solving the issue?

Can you share the .yaml file with us? Maybe it's just a typo...

 

vinicius_rosa
Partner - Contributor III
Partner - Contributor III

apiVersion: v1
kind: ServiceAccount
metadata:
name: tiller
namespace: kube-system
---
apiVersion: rbac.authorization.k8s.io/v1beta1
kind: ClusterRoleBinding
metadata:
name: tiller
roleRef:
apiGroup: rbac.authorization.k8s.io
kind: ClusterRole
name: cluster-admin
subjects:
- kind: ServiceAccount
name: tiller
namespace: kube-system

celindho
Partner - Creator
Partner - Creator

My problem was that I had installed a Docker Desktop version that contains a too new Kubernetes version. Qlik Requires Helm version less than 2.15.x and this requires Kubernetes version less than 1.16.x. I downgraded Docker Desktop to 2.1.5.0 and now I got things up and running.