Skip to main content

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
pauljohansson
Creator III
Creator III

QlikShare Path on Front-End Node

Hi,

A simple Back-End Front-end question.

I intend to have 1 Back-End Node running all services, serving Qlik Devs, Task reloads & also keep the QlikShare

The Front-End node for consumption (Production Role). After installing the Front-End Rim Node I don't see where I can change the path to the apps.  When accessing the Front-End I need the app links to point to where the QlikShare is located on Back-End.

Thanks in advance,

Palu

 

Labels (1)
5 Replies
Alexis_Touet
Support
Support

Hi @pauljohansson 

You Front end node, as all nodes in Qlik Sense will have its engine connected already to the apps shared folder that you have setup when installing Qlik Sense.


You can check that path with https://<your server FQDN>/qmc/servicecluster
Example: 
\\dc1\SenseShare3\Apps

Best regards,

Please don't forget to mark a correct resolution or answer to your problem or question as correct, as it will help other members to find solutions more easily 😉
pauljohansson
Creator III
Creator III
Author

Ok, so then I  guess I need to re-install the Front-End node? Or is it possible to edit the QlikShare path  for the Front-End Node?

thanks in advance,

Paul

JanJorissen
Support
Support

Hi Paul

The easiest way to change the share path is the Qlik Sense Utility under C:\Program Files\Qlik\Sense\Repository\Util\qlik-sense-util

'Connect to database' using postgres user and the db superuser admin password

Then set the new path in the Service cluster settings
 

pauljohansson
Creator III
Creator III
Author

Hej @JanJorissen and @Alexis_Touet 

 


When I use qlik-sense-util the paths are correct, including the QlikShare. I'm also able to access apps when i connect to the back-end node. However, when I connect to the Front-end node HUB to open a app, the path becomes localhost. To sum app:

Connecting to the Back-End Node, all good, paths are OK, app opens:

pauljohansson_0-1648627325832.png

 

 

Connecting to the Front-End Node. Apps are listed OK. But when opening an app, path points to localhost, hence app not found:

pauljohansson_1-1648627390913.png

 

 

br Paul

JanJorissen
Support
Support

Hi Paul

Do you mean that when opening the hub it opens on for example https://server.domain.com/hub , but then when you open an app it wants to open on https://localhost/hub

Did you take your last screenshot when logged on to the newly installed node?

If the URL for the hub  on that node points to the proxy of the other node, make sure that the virtual proxy on that proxy load balances to both servers