Qlik Community

Ask a Question

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Our May 2021 end-to-end product release from Data Integration to Data Analytics is out! READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
gandalfgray
Specialist II
Specialist II

Reloads Monitor 7.10 can't find task executions (view_task_execution_scheduler is empty)

Hi!

We are trying to use Reloads Monitor 7.10.

We are using centralized logging to a log database.

Reloads Monitor 7.10 reads the log view 

view_task_execution_scheduler

but gets 0 results.

Which means we do not get anything in the Reloads Monitor app from QMC Task executions.

 

All logging and tracing at the scheduler is set to "Info" level.

 

How can we fix this?

Labels (1)
12 Replies
jpjust
Contributor III
Contributor III

All,

I have the same issue. Does anyone know the cause?

I have 2 Qliksense environments with separate QLogs database on Postgres

One environment of the qliksense brings data from view_task_execution_scheduler table but the other one did not.

Thanks

 

Bastien_Laugiero

Hello @jpjust,

Have you checked in the QLogs database if the view_task_execution_scheduler is populated with data?

The only support case I have found with these symptoms was due to a reset of the QlikCentralizedLogging.config under C:\Programdata\Qlik\Sense\Log.

To resolve the issue the qlog_reader and qlog_writter password was updated and after a service restart it started to work again. https://help.qlik.com/en-US/sense-admin/February2021/Subsystems/DeployAdministerQSE/Content/Sense_De...

Hope this helps!

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
jpjust
Contributor III
Contributor III

Hi Bastien,

I have done some debugging and see my observations below. Please let me know if you have any suggestions.

The issue is, the reload app is not bringing in the details of scheduled qmc reload tasks because the underlying postgres view (view_task_execution_scheduler) is empty.

There are 2 tables as below that feed data to that view

select  * FROM archive_entries a where process_name='scheduler' order by entry_timestamp desc

select  * FROM log_entries a where process_name='scheduler' order by entry_timestamp desc

The payload json fields for those 2 tables are not populated with data for process_name=scheduler. Eg., Status and other fields are empty, Please see the below screenshot.

Please let me know what could be the issue?

payload-json.jpg

gandalfgray
Specialist II
Specialist II
Author

Hi JP

Make sure you have the Scheduler(s) "Task execution log level" set to "Info" (or possibly "Debug" but that is quite noisy).

If you don't have that you will not get the view_task_execution_scheduler populated

Bastien_Laugiero

Hello @jpjust

Looking at the screenshot, the logger is "System.Scheduler.Scheduler.Slave.Execution.Executor". For this logger, it is expected that the status and other fields are empty. 

The logger being available in the "view_task_execution_scheduler" view is  "TaskExecution.Scheduler.Scheduler.Master.Task.TaskSessionState" and this one should have the status and other fields populated. 

Do you have entries for that logger in the "log_entries" or "archive_entries" table?

If not I would suggest to check first the log level for "Task execution log level" as mentioned by @gandalfgray 

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
jpjust
Contributor III
Contributor III

Hi Bastien,

I don't have any records when I run the query on log_entries and archive_entries tables.

select * from log_entries where logger='TaskExecution.Scheduler.Scheduler.Master.Task.TaskSessionState'

I do have another single node dev environment and I can't preproduce this issue.

The Scheduler(s) "Task execution log level" is set to "Info" on both Dev and Prod (multi-node) environments.

Any other suggestions?

Thanks

Bastien_Laugiero

Hi,

That's interesting. These entries are written by the "Master/Manager" scheduler which in most environment is the central node.

When you look at the table log_entries table, do you see any rows from the process_host which is configured as "Master/Manager" scheduler?

If you see entries from this host, then I would suggest to enable the logging service logs and see if there is any error. To do that you can follow the instruction here https://community.qlik.com/t5/Knowledge-Base/How-to-enable-logging-for-the-QlikSense-Centralized-Log...

 

Finally, if you do not have a specific use case scenario with QLogs, it is always possible to configure the monitoring apps to read from the log files instead of QLogs. For that you can follow the instructions provided here

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
jpjust
Contributor III
Contributor III

Hi Bastien,

There are no rows specific to the central node on log_entries table. There are rows from RIM node (scheduler node as well) but as I mentioned above the table is empty for logger='TaskExecution.Scheduler.Scheduler.Master.Task.TaskSessionState'

Should I open a case with support ?

Thanks

Bastien_Laugiero

Thanks!

Ok so if there are no rows from the central node in the log_entries table then it means that the connectivity between the central node and the QLogs database is not working. My last suggestion would be to verify the connectivity from the central node by doing: 

cd C:\Program Files\Qlik\Sense\Logging
Qlik.Logging.Service.exe validate

The output should be something like

        archive_age_in_hours: 168
        last_forced_db_trim: 2021-05-04 10:51:12.827085+02
        purge_age_in_hours: 336
        version: 0.7

        CentralizedLoggingEnabled: True
        LoggingToFileEnabled: True
        MaximumDatabaseSizeInGB: Max db size not enforced
        DB Host: QlikServer3.domain2.local
        DB Name: QLogs
        DB Writer User: qlogs_writer
        DB Reader User: qlogs_reader
        DB Port: 4432

If you get something different, you may want to try the following command and then restart the logging service to update the connection string: 

cd C:\Program Files\Qlik\Sense\Logging

Qlik.Logging.Service.exe update -h database_server -p 4432 -r Password-for-qlogs_reader -w Password-for-qlogs_writer -d on

 

Hope this helps!

Bastien Laugiero
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.