Qlik Community

GeoAnalytics

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Announcements
Join “Do More With Qlik” with Mike Tarallo to get a first-hand look at the New Authoring Experience, June 29th: REGISTER HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
odedko
Contributor II
Contributor II

Using Qliksense with GeoServer on-Premise, no internet connection

Our platform is deployed on-premise, without an internet connection (security reasons).

We have a qlikview server that gets maps from geoserver, using an openlayers extension.

How do we do that with qliksense? We do need the geo analytics. Just the ability to connect to our local geoserver.

I tried it with qliksense, but it seems that our geoserver should be available to qlik's cloud...

Any idea?

Labels (2)
3 Solutions

Accepted Solutions
danielrozental
Master II
Master II

Are you using Qlik Sense Cloud or Enterprise Edition On Premise? Considering your security concerns probably On Premise makes more sense.

If you add a background layer then you can connect to geoserver using TMS or WMS format.

View solution in original post

danielrozental
Master II
Master II

Patric_Nordstrom
Employee
Employee

Make sure the internal ge server has a proper certificate and is reachable from the client browser. Most browser blocks mixed http and https content. Use the Javascript console (F12) to find connection problems.

Thanks

Patric

View solution in original post

5 Replies
danielrozental
Master II
Master II

Are you using Qlik Sense Cloud or Enterprise Edition On Premise? Considering your security concerns probably On Premise makes more sense.

If you add a background layer then you can connect to geoserver using TMS or WMS format.

odedko
Contributor II
Contributor II
Author

Hi Daniel

Thanks for your response.

Yes, its qliksense on premise.

The problem is that we do not succeed in getting the background from geoserver.

Its very unclear how exactly it should be configured in the layer parameters in qliksense.

Thanks

Oded

 

danielrozental
Master II
Master II

Can you try your WMS URL like this? This just worked for me.

https://basemap.nationalmap.gov/arcgis/services/USGSImageryOnly/MapServer/WMSServer

You can also try TMS with a URL like this

http://a.basemaps.cartocdn.com/light_all/{z}/{x}/{y}.png

odedko
Contributor II
Contributor II
Author

We already tried something like this with the geoserver wms service. Somehow it refuses to work.

We did not try TMS.

Maybe we should...we will look into it.

Thanks

Oded

 

Patric_Nordstrom
Employee
Employee

Make sure the internal ge server has a proper certificate and is reachable from the client browser. Most browser blocks mixed http and https content. Use the Javascript console (F12) to find connection problems.

Thanks

Patric