Qlik Community

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
Showing results for 
Search instead for 
Did you mean: 

Getting error -onLicenceAccessDenied in Qlik mashup embedded in SharePoint using iFrames


I have a Qlik Sense mashup extension embedded in Sharepoint using iFrames. The solution is build in a way  that all components are grouped and delivered within 6 embedded iFrames, anticipating restrictions of IE. 

I have number of users who recently reported, that when accessing the dashboard in SharePoint, and after making few selections, the whole mashup goes blank (no data being pulled in) and when they check the developer tools, they can see that there is an error message saying "onLicenceAccessDenied". 

Now, I would usually ask them to close their browser and to wait for 5-10 mins and then to get back to the same dashboard for a new session to be allocated to them. However, what few of them reported is, that even after closing the browser and leaving it closed for a whole night, on their return to the dashboard they still get the same error message and dashboard is blank. 

Anyone has an idea why this might be happening? Does that have something to do with browser storing session details? 

Every help is very much appreciated...

Labels (3)
2 Replies

When u wrote "anticipating restrictions of IE"
Do u talk about having 6 concurrent  websockets open  ?

It sounds to me that having 6 (!) iframes requires to write real mashup (using qlik API) and not use 6 iframes, seem to me this is not going to be stable solution anyway


yes, 6 concurrent web sockets. 

I appreciate your opinion her, however iFrames were chosen for this solution for a valid reason. The question that I have is not about how the solution is build or to get opinion on the same. My question here is why some users are able to access application with no issue, and some are getting error message above. 

I had a session with a user today that used Google Chrome. The user was getting same error message as described above...After asking him to close all tabs, clear cache (browsing history, cookies, etc.) only then the user was able to connect to Qlik to see data. Please note, the mashup was fully visible, it just did not have any data.