Skip to main content

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
bobbiros
Contributor III
Contributor III

REST API works in QS Desktop but fails in QS Server

Qlik Sense - Data Connectivity

I have a REST API data connection configured that works fine in the QS Desktop version.

However, the same REST API, configured the same way, fails on QS Server (Sept 2017 release) during the data connection creation process (TEST CONNECTION) with error:

Should a REST API data connection that works on QS Desktop work the same on QS Server?

1 Solution

Accepted Solutions
bobbiros
Contributor III
Contributor III
Author

We were able to get this diagnosed and resolved through the assistance of Qlik Support.

The Internet Explorer browser settings on the Qlik Privileged Service Account had never be setup.

I remote connected to the Qlik Server as the Service Account.
Accessing IE for the first time setup/configured some corporate LAN/Configuration script settings.

Now the REST connection works from my QS Server.

View solution in original post

1 Reply
bobbiros
Contributor III
Contributor III
Author

We were able to get this diagnosed and resolved through the assistance of Qlik Support.

The Internet Explorer browser settings on the Qlik Privileged Service Account had never be setup.

I remote connected to the Qlik Server as the Service Account.
Accessing IE for the first time setup/configured some corporate LAN/Configuration script settings.

Now the REST connection works from my QS Server.