Skip to main content

Monitoring & Administration

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
qs123
Contributor II
Contributor II

App Table list not loading in Metadata Analyzer app

Hi fellow admins,

 

We have recently implemented Qlik Sense multi-node on premise in our small company. I wanted to use  Metadata dashboard specifically to answer following question.

Which Qlik Sense App is using which QVD tables.

I did import the  App Metadata Analyzer.qvf and updated the host name and its loading..

 It is showing me the list of apps and streams but not showing which table is being used in which app.

Am I missing any configuration?

Thank you

1 Solution

Accepted Solutions
qs123
Contributor II
Contributor II
Author

This is now fixed 🙂 I was running the load using my Qlik admin account but did not have one of the API permission enabled. Thank you all.

View solution in original post

7 Replies
rzenere_techedge
Partner - Specialist
Partner - Specialist

Goodmorning @qs123 ,

which version of Qlik Sense are you using? Metadata cannot be read before June 2018 version
Have you done any configuration inside the app, once imported? One of the requirements is to define a variable to point to the central node of your infrastructure.

Hope this helps,
Riccardo

Clever_Anjos
Employee
Employee

Which user you are using to reload the app? 

Usually I change the owner to sa_repository and mark this user as RootAdmin

qs123
Contributor II
Contributor II
Author

Thank you for your replies guys

 

@rzenere_techedge  - Our current version is Qlik Nov 2019 version. And yes, the only configuration I changed within the load script is to point it to our central node. So the load script is pulling all the data such as app names, stream names, etc,. but no pulling the table names for apps.

 

@Clever_Anjos  - Yes the App owner is a RootAdmin. 

rzenere_techedge
Partner - Specialist
Partner - Specialist

Good evening @qs123,

I tried on same version and it's running smoothly. 

On the central node virtual proxy, have you set load balancing for all nodes except central node itself? If you try the link used by QS (http(s)://<central node>/api/v1/apps/<app GUID>/data/metadata), what is the result you get?

 

Riccardo 

qs123
Contributor II
Contributor II
Author

Thanks @rzenere_techedge  - Yes the load balancing is correct and I do see the data from API in the browser when I use that URL with required information.

 

qs123
Contributor II
Contributor II
Author

This is now fixed 🙂 I was running the load using my Qlik admin account but did not have one of the API permission enabled. Thank you all.

rzenere_techedge
Partner - Specialist
Partner - Specialist

Good evening @qs123, great! For our knowledge, which permission was not enabled?

Many thanks,
Riccardo