Skip to main content

Official Support Articles

Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!

The number data on the Oracle source landing with .0000000000 extension on the postgresql target, but there is no extension on the source

cancel
Showing results for 
Search instead for 
Did you mean: 
Dana_Baldwin
Support
Support

The number data on the Oracle source landing with .0000000000 extension on the postgresql target, but there is no extension on the source

The numbers being padded with additional zeros should be resolved by changing the "Expose NUMBER as:" setting on the Advanced tab of the source endpoint. Change that to VARCHAR and test to confirm. The value will be cast back to a number on the target.

Environment

  • Replicate 7.0.0.797

Cause

By default, Oracle source endpoints are set to expose numbers as NUMERIC(38,10)

Related Content

https://community.oracle.com/tech/developers/discussion/2578171/largest-number-of-digits-for-number-...

Labels (2)
Comments
akaradhya
Partner - Contributor
Partner - Contributor

I am facing the same issue. Is there a workaround for this issue?

Sonja_Bauernfeind
Digital Support
Digital Support

Hello @akaradhya 

If the workaround mentioned in this article does not achieve the desired results, I recommend posting your query directly in our Qlik Replicate forum to make use of the wider reach into our community and our active support engineers. Feel free to refer back to this article as an example of what you tried.

All the best,
Sonja 

Version history
Last update:
‎2022-02-04 06:51 PM
Updated by:
Contributors