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tESBProviderRequest: 'Port 80 already in use'

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TalendSolutionExpert
Contributor II
Contributor II

tESBProviderRequest: 'Port 80 already in use'

Last Update:

Feb 9, 2024 1:22:49 PM

Updated By:

Jamie_Gregory

Created date:

Apr 1, 2021 6:22:39 AM

Problem Description

When running a Job designed with a tEsbProviderRequest component, you may encounter the following exception:

Exception in thread "Thread-1" java.lang.IllegalArgumentException: Cannot start provider with uri: /gefService/. Port 80 already in use.
at dsi_test.gef_0_1.Gef$HandlerThread_tESBProviderRequest_1.run(Gef.java:814)

 

Root Cause

In this case, the Job is corrupted.

 

Solution

To fix the issue, follow these steps:

  1. Ensure that the WSDL file being used is using port 80, and that the port is available for bidirectional communication.

  2. Then, if you are still encountering the issue; check if the Job is migrated from lower environments to the latest version, if so, perform the following steps:

    1. Delete the existing WSDL file under Services.
    2. Delete the entire Job.

    3. Restart Talend Studio.

    4. Create a new WSDL file under Services.

    5. Create a new Job.

For more information on how to create a WSDL file, see How to create a data service in the Talend Help Center documentation.

Version history
Last update:
‎2024-02-09 01:22 PM
Updated by: