Skip to main content
Announcements
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Antony_05
Contributor III
Contributor III

Unable to add server to Enterprise Manager

Our Team has recently migrated some of our replication jobs to a new server (Replicate v7.0.0.1221).

When I try to connect this new server to Enterprise Manager (v2021.5.0.543), the configuration fails with the  "Replicate server not found" error. 

All the necessary ports are open, we are able to successfully Telnet between AEM server and the new server we're attempting to configure, but when I try to connect it to AEM using the same connection string information, the configuration fails.

Can you please assist me with solving this issue?

1 Solution

Accepted Solutions
SachinB
Support
Support

Hello @Antony_05 ,

You can add both Replicate Servers and Compose Servers to Enterprise Manager. Once a Server is added and monitoring is enabled, Enterprise Manager establishes a connection to it and automatically discovers and retrieves all tasks and messages, along with basic information about the server.

However, You need the admin role to be able to add a server.

Kindly refer to below link for the same.


https://help.qlik.com/en-US/enterprise-manager/May2022/Content/EnterpriseManager/Main/Servers/Adding...

Regards,

Sachin B

 

View solution in original post

10 Replies
DesmondWOO
Support
Support

Hi,

Please make sure port 3552 is opened for outbound and inbound communication and check QEM log if you can find any clues inside. If problem persists, I would suggest opening all ports to check if it is a network issue.

Regards,
Desmond

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
Steve_Nguyen
Support
Support

1. from the QEM server remote desktop, make sure you have telnet client install on the QEM for testing.

- from the QEM server, open command prompt and do : telnet newreplicate7.0server(server name or ip address) 443  ,,, if connect you get a blank screen. (this is for windows replicate server.)

example: telnet 10.118.118.1 443 

 

telnet newreplicate7.0server(server name or ip address) 3552  ,,, if connect you get a blank screen. (this is for windows replicate server.

example:  telnet 10.118.118.1 3552

 

if the telnet test work then QEM should connect , if not then you have network or firewall issue.

 

2. from the QEM server remote desktop,,, open a chrome browser and try to reach the Replicateserver URL does it works?

 

Help users find answers! Don't forget to mark a solution that worked for you! If already marked, give it a thumbs up!
Antony_05
Contributor III
Contributor III
Author

Hi Team,

Thanks for your solutions, I think the port 3552 is not opening in the Attunity server to connect from AEM.

Let me try to open that port. 🙂

Regards,

Antony S

SachinB
Support
Support

Hello @Antony_05 ,

Below are the requirement in order to connect replicate machine.

Qlik Replicate Server requirements

To be able to connect to a Replicate Server, Enterprise Manager requires the following for each Replicate Server to be monitored:

  • A Replicate administrator user. Enterprise Manager uses this user to connect to the Qlik Replicate instance. This means:

    • If the connection is made directly to the replication server, you can use the fixed user name admin. In this case, the default port is 3552. You set the admin user password on the Replicate server using the repctl setserverpassword command, as follows:

      On the Replicate server, run the following command from the bin directory; then restart the Replicate service:

      Repctl.exe setserverpassword <adminPassword>

      For more details, see the Replicate documentation.

    • If the connection is made to the Replicate UI server, you must specify a user with Admin role. This can be the user that installed Replicate, an Active Directory user with the Replicate Admin role, or a member of the AttunityReplicateAdmins Active Directory group.

      The default port is 443. For information on setting user roles within Qlik Replicate, refer to the Qlik Replicate Setup and User Guide.

    It is recommended that you configure this user with a strong password that does not need to be changed frequently. If the administrator password changes, you also need to change it in Enterprise Manager

  • The port that Enterprise Manager uses for connecting to Qlik Replicate needs to be opened inbound on the Replicate server machine. Depending on your network architecture (for example a WAN environment), you may also need to open ports on routers and border firewalls. If you block outbound traffic from the Enterprise Manager machine, you need to make an exception on the Enterprise Manager machine for the ports used to connect to the Replicate Server.

    Here is the link you can follow in future.
    https://help.qlik.com/en-US/enterprise-manager/May2021/Content/EnterpriseManager/Main/Servers/Attuni...

Regards,

Sachin B

Antony_05
Contributor III
Contributor III
Author

Hi Team,

Here the connection is made to Replicate UI server, But I don't have admin credentials to configure this server in AEM.

Can anyone please help me how to get that admin credentials.? 

Regards,

Antony S

SachinB
Support
Support

Hello @Antony_05 ,

 

  1. Go to command prompt (Run as administrator)
  2. Run this command from command prompt, Run the below command after entering the bin directory

    aemctl repository edit -n ::

  1. It will open the document file, Try to add the user the one which you want to give the access for admin role,
  2. Choose 'Yes' in the console to save it back to the repository
  3. Once done above steps, Kindly restart the QEM service and Later try to open the console

 

Regards,

Sachin B

Antony_05
Contributor III
Contributor III
Author

Hi @SachinB ,

I meant for the replicate server not for the AEM. I'm not having the admin credentials for the replicate server which in need to configure in the AEM.

I'm getting the below mentioned error:

[ERROR] Test connection failed for server:SAP_OCI. Message:'AEM-E-SERAUTHINVALD, The remote server returned an error: (401) Unauthorized.'.

Regards,

Antony S

SachinB
Support
Support

Hello @Antony_05 ,

You can add both Replicate Servers and Compose Servers to Enterprise Manager. Once a Server is added and monitoring is enabled, Enterprise Manager establishes a connection to it and automatically discovers and retrieves all tasks and messages, along with basic information about the server.

However, You need the admin role to be able to add a server.

Kindly refer to below link for the same.


https://help.qlik.com/en-US/enterprise-manager/May2022/Content/EnterpriseManager/Main/Servers/Adding...

Regards,

Sachin B

 

Antony_05
Contributor III
Contributor III
Author

Hi Team,

Now I have configured the replicate server successfully in the AEM server after following some steps in the help document.

Thanks for your help. 🙂

Regards,

Antony S