Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Read about the latest Qlik Community enhancements on the Community News blog!
cancel
Showing results for 
Search instead for 
Did you mean: 
anag123456789
Contributor III
Contributor III

On-Demand No Connection with NPrinting Server

Hi Experts,

I've made necessary settings for on-Demand feature but when I'm trying to use it from Access Point than it is giving below Error:

On-Demand Issue.png

If anybody has faced this issue than Please help.

Regards,

Aviral Nag

48 Replies
anag123456789
Contributor III
Contributor III
Author

Hi Chanty,

I've made all the necessary and required settings.

Everything is fine but my question is how do I add reports under on-demand button. See the above Snapshot.

Chanty4u
MVP
MVP

if it created on that server it will show automatically i think.

anag123456789
Contributor III
Contributor III
Author

Fixed the issue. The dashboard should be in the Root folder.

I was earlier using the Mounted Folder.

anag123456789
Contributor III
Contributor III
Author

Hi Daniel/Ruggero/Chanty,

Thank you all for the quick and Timely support.
With your immense knowledge and experience I'm able to achieve the end Result.
It was a great Learning for me.
Once again Thank you so much.

Regards,
Aviral Nag

Ruggero_Piccoli
Employee
Employee

Correct.

If the user that you used to login has access to an app with some reports with the On-Demand and API flag enabled the user will see all these reports without the need of any manual configuration.

All this kind of information are documented in the help site.

Best Regards,

Ruggero

---------------------------------------------

When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads as HELPFUL if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads as HELPFUL if you feel additional info is useful to others.



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
prees959
Creator II
Creator II

Hi,

I am facing a similar problem.  I have added the AccessPoint server as a Trusted Origin :

np trusted origin.JPG

Also,  I am logging into the AP using the same domain\user format as is attributed to my user settings on the nprint console.

When I click the OnDemand button this is the error and also the Chrome Console information :

npondemand error.JPG
Can anyone help / advise please?

Thanks,

Phil

Frank_S
Support
Support

HI @prees959 

Please check the following article.

https://support.qlik.com/articles/000057531

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!
prees959
Creator II
Creator II

thanks @Frank_S  all sorted!

 

 

Frank_S
Support
Support

Great to hear! @prees959 

We are just 'like' you and like to be liked when providing a helpful answer. You may also press the 'Solution Accepted' button if an answer provided resolves your question or issue... Cheers!