Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
See why Qlik was recognized for the seventh year in a row – and discover how we can help you tackle your data integration challenges. Get the report
cancel
Showing results for 
Search instead for 
Did you mean: 
dmac1971
Creator II
Creator II

Pixel Perfect PDF Resolution

Just created my first PDF report and everything is working fine.  As the report had a gauge in it I couldn't replicate it in NPrinting by recreating the gauge chart, so I've went for an image of the full sheet.  This gives me the correct output over two sheets but the resolution is off.

Everything looks fuzzy.  I've already updated QV Export user settings to 400%, and have NPrinting output in high quality but it just looks naff.  What am I doing wrong?

Labels (1)
5 Replies
Natalija
Partner - Creator
Partner - Creator

Hi,

In my experience Export  setting should always be set to 100%. With Pixel Perfect always use option in properties "Zoom Image" and make sure that height and width of image in Pixel Perfect is more or less same as pixels (height and width of object) in QlikView/Sense.

 

Let me know if using "Zoom Image" object property worked for you.

 

 

Natalija

 

dmac1971
Creator II
Creator II
Author

Thanks for reply.  Yes I tried Zoom image already and it didnt help.  What I did was create a template on QV report and made sure all charts etc where inside this template, then I created image in NPrinting of same dimension.  Its close to being correct but that little bit out.

Natalija
Partner - Creator
Partner - Creator

Hi,

 

Can you show preview of reports with 100% and 400% export resolution and zoom image properties applied to object.

Ruggero_Piccoli
Support
Support

Hi,

Refer to https://help.qlik.com/en-US/nprinting/September2019/Content/NPrinting/ReportsDevelopment/Image-quali... and try to increase the image quality on the publish task created to distribute the report.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
andrei_delta
Partner - Creator III
Partner - Creator III

hi,

The message from below is from one of the nprinting's release notes. I tried it and it works. You get very good quality. you can leave that setting to 400%. 

Jira issue ID: OP-7953
Starting from this version, Qlik NPrinting will use all settings under the section User preferences...-> Export >
Copying to Clipboard > Include Caption and Border. The flags will be always reset to their default values,
except for QlikView 12.20 SR7. In this case, only the flag Chart will be enabled as a requirement to use High
Quality images exported for Chart. If the option that disabled the advanced export is disabled in the
Qlikview.config file, all flags will be reset to default values.

 

the path to the cfg file: C:\ProgramFiles\NPrintingServer\Engine\QlikView.config

you uncomment the html line <!-- <useAdvancedImageExport value="true" /> -->

Be aware, it's only working on charts not tables.

hope it helps,

Andrew