Skip to main content
Defect acknowledgement with Nprinting Engine May 2022 SR2, please READ HERE
Showing results for 
Search instead for 
Did you mean: 
Partner - Contributor III
Partner - Contributor III

NPrinting Edit Excel Template Error

Hello everyone,

I would really appreciate your help..

I am trying to Edit my Excel template in NPrinting but I am getting the following error:

"Match method of WorksheetFunction class failed.


After I click OK, the Edit windows opens with my excel template but it seems there is no connection with the qvw and everything from the left side (inserted tables, formulas etc) are missing.

I've made some changes in my qvw but the template has been also updated.

Any ideas..?

Thanks in advance!

4 Replies
Partner - Creator
Partner - Creator

Do you have "Cells" created in the template?

I am also getting the same error when I have Cells created in my template, everything gets lost all of a sudden with the erorr you mentioned.

were you able to resolve this?

Partner - Contributor III
Partner - Contributor III

Hello Manish,

No, I don't have any Cells, just Tables from which I am importing each column one by one.

Unfortunately still I had no luck with it.

Which versions of Qlikview and NPrinting are you using?

I have QV11 and NP16.3 .

As this seems to be a VBA excel function, I thought it had to do with Excel so I recreate the whole excel template from the Nprinting excel editor and not from excel.

It worked fine at the beginning but at same point the same error came up with no obvious reason.

Please let me know if you find anything..

Partner - Creator
Partner - Creator

Yeah.. I also had to recreate my template using NPrinting editor itself.

But for me Cells were the definite problem, I tried creating the template with Cells 3 times, every time suddenly it stopped working. But resorted my solution to use Formulae instead of Cells for labels, it worked fine for me.

Not sure if it crashes again tomorrow but at least it did seem to work fine for an hour and a half

QV11 and NP16.4 for me.

Partner - Contributor III
Partner - Contributor III

I managed to identify the problem but not to explain it..

I opened in excel my template I deleted all the items I have inserted.

Then I opened the report and edit the template in Nprinting and it opened fine.

So thankfully I didn't loose any of the work i did on it (formulas, added objects etc)

Then I was adding my tables and formulas one by one till I found which table was causing the problem.

And it was not the whole table but a specific field of it.

I tried few things, like re-adding the object but with no luck..

I really can't imagine why this is happening!