Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
Finnova
Contributor III
Contributor III

HTTPS- Certificat

Hi, we have a Problem with an HTTPS-Certificat.

I have installed an HTTPS certificate (TLS) with CommonName *.shr.company.ch.

This applies, for example, to the Qlik Replicate UI link: https://test.shr.company.ch  [/attunityreplicate].

I have also already imported the certificate and connected with the appid.

This works so far. However, forwarding to the hostname is now the problem.

Now the certificate is invalid, because I will be redirected directly to https://hostname[/attunityreplicate].

First support says there should be a serviceconfiguraiton file located in the replicate/data directory. But there's not.

Does anyone have a different solution?

Labels (1)
3 Solutions

Accepted Solutions
DesmondWOO
Support
Support

Hi @Finnova ,

Please try following command:

repuictl configuration set --address <your hostname>

Regards,
Desmond

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!

View solution in original post

Alan_Wang
Support
Support

As John has stated, in Replicate 2023.5, the two files have been depreciated and repctl CLI commands should be used to edit any host address configurations. Here is the sample configuration settings that can be adjusted with the CLI commands.

--address ""
--http_port "80"
--https_port "443"
--root_url "attunityreplicate"
--user_timeout "5"
--domain "mydomain.com"
--ad_default_container ""
--authentication_method "SSO"
--static_http_headers
--rest_http_headers
--use_strict_same_site_cookie "False"
If the issue is solved please mark the answer with Accept as Solution.

View solution in original post

Finnova
Contributor III
Contributor III
Author

In this case, it is also helpful to know:
- Data directory is not in the base directory: repuictl -d "Other directory" configuration ...
- The .pem files must be deleted in this data/ssl directory.

It works now. Thank you for your tips

 

View solution in original post

14 Replies
john_wang
Support
Support

Hello @Finnova ,

Thanks for reaching out to Qlik Community!

Not sure if you are meaning these two files. The ServiceConfiguration.xml and ServerConfiguration.xml files have been deprecated from Replicate version 2023.5. Operations that were previously performed by editing these files are now performed using the Replicate CLI command. A similar article: Regarding serviceconfiguration.xml file.

Hope this helps.

John.

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
Finnova
Contributor III
Contributor III
Author

That explains the missing files, thank you.
However, I always lack the information on how to solve the forwarding of the website so that my HTTPS wildcard certificate works.

DesmondWOO
Support
Support

Hi @Finnova ,

Please try following command:

repuictl configuration set --address <your hostname>

Regards,
Desmond

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
Finnova
Contributor III
Contributor III
Author

In this case or when I try the cmd repuictl configuration show I become the following request:

Operation failed (reason: REPO-E-FACSQLREP, Failed to connect to SQLite repository 'D:\Program Files\Attunity\Replicate\data\GlobalRepo.sqlite'.)
Command ShowHostConfigurationCommand failed.
REPO-E-FACSQLREP, Failed to connect to SQLite repository 'D:\Program Files\Attunity\Replicate\data\GlobalRepo.sqlite'.

In summary:

  • My Version: 2021.11.0.469
  • ServiceConfiguration.xml does not exists
  • GlobalRepo.sqlite does not exists

What I have is a ServersConfiguration.xml. Can I configurate there? If so, do you have an example?
I have also tried via cmd Aemctl.exe. But this application also does not exists.

DesmondWOO
Support
Support

Hi @Finnova ,

Replicate  v2021.11.0.469 should have ServersConfiguration.xml and ServiceConfiguration.xml under data folder.

If both Replicate Server and Replicate UI are  on the same machine, the content of these two files should be as below:

ServersConfiguration.xml

<?xml version="1.0" encoding="utf-8"?>
<ServersConfiguration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<Servers>
<ServerData name="local" host="127.0.0.1" port="3552" description="Local Attunity Replicate Server" />
</Servers>
</ServersConfiguration>

ServiceConfiguration.xml
<ServiceConfiguration url="https://<your hostname>:443/attunityreplicate;http://<your hostname>:80/attunityreplicate" allowUnsafeProtocols="false" />

** Please change <your hostname> according to your network configuration.

Please note that Replicate v2021 has reached its end of support date and it is unusual that these two files are missing. I suggest reinstalling the supported version. For details, please check the release note.

Regards,
Desmond


Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
Alan_Wang
Support
Support

Hi @Finnova 

Did you install the data directory in a separate location from the base installation? Trying locating the ServiceConfiguration.xml file from the data directory that was designated as the separate location. It is recommended to ensure the Replicate services are turned off before editing these configuration files.

 

If the issue is solved please mark the answer with Accept as Solution.
Finnova
Contributor III
Contributor III
Author

We updated now Replicate to 2023.5.
We found another data folder on a other location on the same host with a serviceconfiguration.xml.
Also we ad a serviceconfiguration.xml to the data folder in base location with following configuration:
<ServiceConfiguration url="https://test.shr.company.ch:443/attunityreplicate;http://test.shr.company.ch:80/attunityreplicate" allowUnsafeProtocols="false" />

The certificate is still invalid, because of the forwarding to https://hostname[/attunityreplicate].

Server und service was restartet.

Any other ideas?

Alan_Wang
Support
Support

As John has stated, in Replicate 2023.5, the two files have been depreciated and repctl CLI commands should be used to edit any host address configurations. Here is the sample configuration settings that can be adjusted with the CLI commands.

--address ""
--http_port "80"
--https_port "443"
--root_url "attunityreplicate"
--user_timeout "5"
--domain "mydomain.com"
--ad_default_container ""
--authentication_method "SSO"
--static_http_headers
--rest_http_headers
--use_strict_same_site_cookie "False"
If the issue is solved please mark the answer with Accept as Solution.
Finnova
Contributor III
Contributor III
Author

Thanks, it was a little confusing because the data directory is in a different location.

I have now set --address "hostname".
The forwarding still happens after a service restart and the certificate is therefor not valid.